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The Denali eDelivery solution easily integrates with Denali and allows you to email
invoices, statements, pay stubs, and purchase orders. After you set up eDelivery, you
can access your Denali customers, vendors, and employees and email them invoices,
statements, purchase orders, and pay stubs to the email address set up in Denali or a
different email address. You can also preview and print all your documents before
emailing them.
You must purchase one 12-month license per workstation and user.

Installing Denali eDelivery
After you purchase Denali eDelivery, you will be given access to the website location from which you
can download the program. If you run Denali 64-bit, choose the 64-bit version of eDelivery. If you run
Denali 32-bit, choose the 32-bit version of eDelivery.
To install Denali eDelivery:

1
2
3
4
5
6
7

After you purchase eDelivery, download the program to the workstation on which you will use it.
Navigate to the folder where you downloaded the program and open the ZIP file.
Click on Setup.exe to start the installation.
In the Setup Wizard, click Next.
In the Setup Installation Folder window, you can keep the default installation path or change the path
to the location where you want to save the installation. After your path is set, click Next.
Click Next in the Confirm Installation window. eDelivery will begin to install.
Click Close when the installation is complete.
The eDelivery icon will appear on your desktop.

Logging in to eDelivery
To begin using eDelivery, you must first log in and integrate the program with Denali.
To log in to eDelivery:

1

Click the eDelivery icon on your desktop or open the program through the Start menu. The Login to
Database window will appear.
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Figure 1: Login to Database window

2

In the Login to Database window, you need to enter your Denali server location in the Denali SQL
Server field. You can paste information into this field.
If you need help finding your Denali server location, see “Finding the Denali Primary Server Location”
on page 3.

3

Leave the defaults for the other settings, and select OK. The eDelivery program opens.

Finding the Denali Primary Server Location
To integrate eDelivery with Denali, you must enter your Denali server name in the eDelivery Login to
Database window.
To find your Denali server name:

1
2
3
4

Open Client Utilities from your desktop.
From the menu, click Primary Server Location.
In the Select Registry Location window, select OK.
In the Primary Server Location window, copy the information in the Server field.

Figure 2: Denali Primary Server Location
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5
6

Cancel out of this window and close the Select Registry Location window and Client Utilities menu.
Return to the eDelivery Login to Database window and enter the server information in the Denali
SQL Server field.

Setting Your Defaults
Now that eDelivery is installed and integrated with Denali, you need to set some defaults.
To set up your eDelivery defaults:

1

From the menu bar, select Tools > Default Options. The Default Options window opens.

Figure 3: Default Options window

2
3

From the Denali Company Code drop-down, select the company you want to send emails from.

4

In the top part of the Email Configuration section, enter your host email service information. You
might need IT assistance for this step.
From the Auth Type drop-down, you must select Login and you must select the Use SSL check box.

If you will be sending check stubs and you want to require your employees to enter a password to view
their stubs, select the Password Protect Check Stubs check box. Passwords are managed in the
Employee Password Maintenance window (see “Managing Employee Passwords” on page 12).

For specific information about the fields in this window, see “Default Options Field Information” on
page 5.
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5

From the Process drop-down in the bottom part of the Email Configuration section, select one of the
document types you will send: Invoice, Statement, PR Check Stubs, or Purchase Order.

6
7

Enter the default email information for that document type.

8

From the Email Dashboard Default Date drop-down, select the default date range you want to use to
for documents that appear in the Email Dashboard. You can change this range in the Dashboard. See
“Sending Emails with eDelivery” on page 13 for information about the Dashboard.
Click the Test Email button and enter an email address where you want to send a test message. This
ensures all your settings are correct.

9 After you receive the test email, click Save.
10 Set the defaults for each document type you will send by selecting the different options from the
Process drop-down. Your defaults for each type will be saved.

Default Options Field Information
This is information about each field in the Default Options window.
Denali Company Code
After you enter your Denali server information in the Login to Database window, you can select the
Denali organization you want to connect to from this drop-down.
Password Protect Check Stubs
If you want employees to enter a password to view their check stubs, select this check box.
Outgoing Email (SMTP)
Enter your outgoing email host server.
Email User
Enter your email login for the email address you will send emails from.
Email Password
Enter the password for the email address you entered in the Email User field.
Auth Type
From this drop-down, select Login. This is the login type for your email host.
Use SSL
You must select this check box. It sets the security encryption for your email server.
Email Port
Enter the port number for the email you will use; you can get this from your IT Department or your email
provider.
Send BCC to Self
Select this check box if you want to send a copy of the emails to yourself.
Mark Invoice ‘Printed” When Emailed or Printed
Select this check box if you want the invoice to show as printed whether it is emailed or printed.
Process

Denali eDelivery
Setting Your Defaults

5

From this drop-down, select the type of document you want to define default settings for. You can
choose from Invoice, Statement, PR Check Stubs (if you have a license for this), or Purchase Order.
You can define and save defaults for each type.
Email From
Enter the return email address for the documents you will send.
Email Subject
Enter a subject line for the emails of this process type. You will not be able to change the subject when
you send emails through the Dashboard.
If you want to include custom information for each email, you can include many fields from the SQL
Database. To include a wildcard, enter the field name in brackets. For example, your subject could be
Your Monthly [InvoiceType] [strInvoiceNo].
Email Body
Enter a body message for the emails of this process type. You will not be able to change this message
when you send emails through the Dashboard.
Read Receipt Requested
If you want to receive an email when your recipients read the emails you send, select this check box.
Email Dashboard Default Date
From the drop-down, select the default date range you want to view documents for in the Email
Dashboard. This is set for all Process types. You can change this range in the Dashboard.
Activate Multiple PR Paystubs
This feature allows you to set up custom pay stubs for different employees in Denali. Select this check
box to open the PR UDF field where you can enter the UDF field of the custom format.
For instructions on how to use this feature, see Setting Up Custom Checks/Sutbs for Different
Employees on page 6.
Test Email
Click this button after you define all your settings in the window. This confirms your email will be sent
properly.
In the Enter email address window that appears, enter the email address you want to send your test
email to.

Setting Up Custom Checks/Stubs for Different
Employees
If you have custom Payroll checks/stubs for certain employees, you can set up eDelivery to access the
custom check/stub and send it to the correct employee. The first part of the setup is done in Denali and
the last part is done in eDelivery.
To set up custom checks/pay stubs:

1
2
3

In Denali Payroll, click Options > Set Up the Module Preferences from the left navigation pane.
Click the User-Defined Fields tab and then the Add or Edit User-Defined Fields button.
Create a new Text type field for the custom report. This is the field that will appear in the Employee
Maintenance window where you can set the report name for each employee. For example, you could
name this UDF text field PR Alt Stub.
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Click OK.

Figure 4: PR Add or Edit User Defined Fields, add a Text field

4

On the User-Defined Fields tab, click Click here to add a new row to add this field to your PR UDFs
and click OK.

Figure 5: PR Module Preferences, User-Defined fields tab
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5

Select Options > Codes > <UDF Name> from the top menu bar and create a code for each different
check/stub type. Make sure these code names exactly match the report names.

Figure 6: PR UDF Code with Lookup window

6

Open the PR Employee Management window, and for each employee that has a custom stub, enter
the stub name in the UDF field.

Figure 7: PR Employee Management, User-Defined Fields tab

7
8

Open eDelivery and click Tools > Default Options from the top menu bar.
Make sure the Denali Company Code is set to the correct company.
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9 Check the Activate Multiple PR Paystubs check box. The PR UDF field will appear.
10 Use the Browse button to open the Lookup that contains your PR UDF text fields and select the UDF
for this stub.

Figure 8: Default Options window, Activate Multiple PR Paystub
When you email your checks/stubs, eDelivery will use the stub shown on the employee record. If there
is nothing defined, the default check/stub will be used.

Setting Preferences
There are two preferences you can set from the Options menu. To set these, click Options from the
menu bar and then select the option to turn it on or off. A check mark indicates the option is on.
Show Menu on Left
This option toggles on and off the navigation pane on the left side of the window.
Show Logon When Starting
This option allows you to choose whether or not the log in window appears each time you open Denali
eDelivery.
Minimize to Tray
If you want eDelivery to minimize to the system tray (notification area in the Windows Taskbar) instead
of the main Taskbar, toggle this option on.
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Adding Your User License
After you set your default email information, you need to enter your license before you can use
eDelivery.
To enter your eDelivery license:

1

From the menu bar, select Help > License Manager. The License Manager window opens.

Figure 9: License Manager window

2
3

In the License Manager window, enter your company name and contact information.

4

After you receive the email with your license, save the license attachment to any location on your
workstation.

5
6
7
8

In the License Manager window, click the Browse button next to the License File field.

Click the Email Cougar Mountain Support For Your License button.
You will receive your license at the email address you enter here by the end of the next business day.

Navigate to the location where you saved your license and click Open.
Click the Import License File button. Your license expiration date will appear.
Close the License Manager window.

Backing Up and Restoring Your Settings
The backup and restore options are found on the Tools menu. They allow you to back up and restore
your eDelivery settings.
To back up your settings:

1
2
3

Select Tools > Backup from the menu bar.
In the Backup Database window, select the folder where you want to store the backup.
Select Ok.
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To restore your settings:

1
2
3

Select Tools > Restore from the menu bar.
In the Restore Database window, select the folder where you saved your backup.
Select Ok.

Managing Custom Reports
If you have custom statements, invoices, check stubs, or purchase orders in Denali, you need to
customize them again in eDelivery. eDelivery does not use Denali reports. Any reports you customize
will be used by all eDelivery users.
To customize reports in eDelivery:

1

Select Tools > Manage Custom Reports from the menu bar. The Manage Custom Reports window
opens.

Figure 10: Manage Custom Reports window

2

In the Custom Reports Directory field, use the browse button to choose the folder where you want to
save your custom reports.

3
4

After you choose the path, select the Save Path button.

5
6

Use the check boxes in the Selected column of the grid to choose the reports you want to customize.

7

Use Crystal Reports to modify the reports in the custom folder and then save the reports in the same
location.

If you want to save the custom report only for a specific company, choose the company from the Copy
To Directory drop-down. If you want to use the custom report in all companies, do not select anything
here.
After you select all the reports you want to customize, click the Copy Selected Reports button. This
copies the reports to the folder you specified in the Custom Reports Directory field.
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8

If you want to create custom reports for different companies, repeat these steps for each company that
needs custom eDelivery reports.
When eDelivery generates the report you will email, it checks the report locations in the following order:

• Company specific folder: If you customized a report and chose a specific company from the
•
•

Copy to Directory drop-down, this report will be used.
eDelivery custom folder: If you customized reports, but did not choose a specific company from
the Copy to Directory drop-down, the report saved in the Custom Reports Directory folder
will be used.
Default eDelivery report: If you do not customize your reports, the default eDelivery report will
be used.

Managing Employee Passwords
If you will email check stubs and you selected the Password Protect Check Stubs check box in the
Default Options window, you need to set up employee passwords.
To manage employee passwords:

1

Select Dashboards > Employee Password Maintenance from the menu bar. The Employee
Password Maintenance window opens.

Figure 11: Employee Password Maintenance window

2
3
4

From the Company Code drop-down, choose the company you want to manage passwords for.

5

In the maintenance grid, click in the password fields for any passwords you want to change and type
the updated passwords.

6

Click the Save Changes button.

Click the Load Data button.
If you don’t see the employees in the grid, click the Import Employees From Denali button to bring
your Denali employees into the eDelivery program.
Employees are assigned a default password of their last name plus their ZIP code.

Passwords are case sensitive. You cannot save blank passwords.
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Sending Emails with eDelivery
After you set all your options and make any necessary customizations to your reports, you can send
emails in the Email Dashboard window.
If you’re emailing pay stubs, you must send the emails before you post payroll.
To send emails with eDelivery:

1

Select Dashboards > Email Dashboards from the menu bar. The Email Dashboard window opens.

Figure 12: Email Dashboard window

2
3
4

From the Process drop-down, select the type of document you want to send.

5

If you need to change the default date range, enter the dates or open the drop-down calender to select
the dates you want to use.

6

If you are sending invoices or check stubs and want to limit your criteria to a specific batch, use the
Batch drop-down to select it.

7

Click the Load Data button to load the customers/vendors/employees into the grid that match your
criteria.

8

In the Selected column, check the boxes for the invoices/statements/check stubs/purchase orders you
want to email.

9

Click the Send Emails button when you are ready to send out your emails. Emails will be sent to the
email addresses listed in all checked rows.

From the Format drop-down, select the output format for the document type you selected.
If you want to filter which customers/vendors/employees appear in the grid, use the Start and End
filters. You can type the names or access the Lookup by double-clicking in the fields.

• If you need to change an email address, you can change it directly in the Email Address field.
Click in the field and type the address you want to use. This change will not be saved.
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•
•
•
•

You can click the printer icon in the grid to print your document.
You can click the preview icon in the grid for an on-screen preview of your document.
You can click the envelope icon in the grid to send an email for only that row.
You can use the Current and History tabs to access open and posted transactions.

Tips & Tricks: How Do I Change the Subject or Body of My

Email?

If you need to modify the subject or body of an email, you have two options.
• Change the information in the Default Options window, send the email to
the person that required the different text, and change the default information
back.
• Save the report as a PDF and send the email directly from your email
program. To save the report as a PDF, first click the preview icon to preview
the report. In the preview window, click the Export Report button. From the
Save as type drop-down choose PDF and save the report to any location.
You can then attach the PDF in an email.

Using eDelivery Filters
In the Dashboard window, you can use filters to group your search results.
Grouping Bar
Use the grouping bar to group data based on column headings. Drag any column heading to the
grouping bar to refresh the grid and show the gouped data. You can drag multiple column headings to
the grouping bar to further group your data. To undo a grouping, click the X in the corner of the button
in the grouping bar.
Filter Icon
Click the funnel-shaped filter icon at the top of the columns to set the type of filter you want to use. Some
columns have different filter options based on the column type.

Denali eDelivery
Sending Emails with eDelivery

14

7180 Potomac Dr.
Boise, Idaho 83704
Sales: (800) 388-3038
Customer Support: (800) 390-7053
Forms & Supplies: (800) 454-1660
www.cougarmtn.com

