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Tools for Scienti c Creativity

Scienti c WorkPlace, Scienti c Word, Scienti c Notebook, and Scienti c Viewer
set the stage for your creativity with their straightforward approach to working with
mathematics and text. Together, they combine the ease of entering text and mathematics
in natural notation with the power of symbolic and numeric computation, the exibility
and beauty of printed or typeset output, and the convenience of direct Internet access.
Individually, they offer capabilities and features combined to meet a range of user needs.
Version 5 brings new features and enhancements to the MacKichan Software family
of products: typeset PDF output, improved RTF import and export with MathType support, improved HTML and MathML export, and an improved user interface. Scienti c
WorkPlace and Scienti c Notebook contain the MuPAD computer algebra engine.
Explore Version 5 now. Make sure you have what you need to run the software, then
complete the installation and enter the world of scienti c creativity.

Understanding the Product Differences
With all four MacKichan Software products—which we refer to individually by their
initials—you can work with an easy-to-learn, easy-to-use scienti c word processor.
Your text appears on the same screen as mathematics, which you create using familiar mathematical notation instead of special codes. With SWP and SNB, you can perform a wide range of mathematical computations using a fully integrated computational
engine, and you can create interactive course materials using the Exam Builder.
Using any of the products, you can format documents by selecting a style and applying tags, rather than by entering detailed formatting instructions for each text element.
SWP and SW have the added capabilities of TEX, with which you can produce beautifully typeset text and mathematics. With all four products, you can access the Internet
directly. Available at no charge, SV provides an easy way to explore many of these features. Those who haven't purchased SWP, SW, or SNB can use SV to view and print
documents created with the software, whether those documents are available on your
local system or on the Internet.
Capabilities and Features
Document creation and printing
Typesetting with LATEXand PDFLATEX
Computation and plotting
Internet browsing and printing
HTML output with MathML
RTF output with MathType
Creation of interactive course
materials with Exam Builder

SWP

SW

SNB

SV
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Understanding the New Version
The program is characterized by a rich interface, beautiful output, natural entry of text
and mathematics, and easy creation of complex documents. Version 5 brings additional
capabilities and features to the workplace.

Compatibility
You can interact with colleagues more easily and distribute your documents in different
formats when you take advantage of new and enhanced export lters in Version 5.
Export your documents as RTF les. You can now export your SWP, SW, and
SNB documents as Rich Text Format (RTF) les, so that interactions with colleagues
in non-TEX environments are simpli ed. The RTF export preserves the formatting
you see in the document window. Any mathematics in your document can be represented with MathType 3 (Equation Editor) or MathType 5 objects. The resulting
RTF le can be viewed in Microsoft Word even if an Equation Editor is not part
of the Word installation. If the Microsoft Word installation includes the appropriate
Equation Editor, any MathType 3 or MathType 5 mathematical objects in the RTF
le can be edited. The le can also be displayed in outline mode.
Read MathType mathematics in RTF les. In Version 5, you can open and read
the MathType equations in RTF les when you import the RTF les in SWP, SW,
or SNB. The equations are converted to LATEX.
Create more accurate HTML les. When you export your SWP, SW, or SNB
documents to HTML, the program now places any graphics generated during the
process in a subdirectory. Version 5 successfully exports xed-width tables to HTML
and saves the screen format to a Cascading Style Sheet (.css le). With HTML
exports, you can make your mathematics available on various platforms over the
Internet and in applications that can read HTML les.
Export mathematics as MathML. When you export HTML les, you can output
your mathematics as MathML or graphics. Note that not all HTML browsers support
MathML.

Typesetting
Version 5 of SWP and SW provides new typesetting capabilities and many new document shells, some intended for international use.
Create typeset PDF les. Now you can share your work across platforms in Portable
Document Format (PDF) les by typesetting your SWP and SW documents with
PDF LATEX. No extra software is necessary to generate PDF les. The program automatically embeds fonts and graphics in the PDF le.
Use PDFTEX to process les that contain graphics. Until now, using PDFTEX with
most graphics le formats has been tedious or impossible. Before typesetting your
document with PDFLATEX, Version 5 of SWP and SW converts any graphics in the
document to formats that can be processed by PDFLATEX.

Understanding the Logical Design Approach
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Preserve LATEX cross-references in PDF les. If you add the hyperref package to
your document, any cross-references in your SWP or SW document are converted
to hypertext links when you typeset with PDFLATEX. The package extends hypertext
capabilities with hypertext targets and references. Additionally, PDFLATEX fully links
the table of contents in the resulting PDF le and includes in the le hierarchical
markers and thumbnail pictures of all the pages in the document.
Rotate text in PDF les. If you create PDF les from your SWP and SW documents, you can take advantage of the rotating package to rotate parts of text within
the PDF le.
Use expanded typesetting documentation. A new edition of Typesetting Documents in Scienti c WorkPlace and Scienti c Word provides more typesetting tips and
information about more LATEX packages. Learn how to tailor typesetting speci cations from inside the program to achieve the typeset document appearance you need.
Examine an expanded gallery of shells. View images of sample documents for
each shell provided with the program in A Gallery of Document Shells for Scienti c
WorkPlace and Scienti c Word, provided on the program CD as a PDF le. Use the
documentation to choose document shells appropriately.
Choose shells tailored for international documents. Version 5 includes new shells
for documents created in non-English languages, including German, Japanese, Chinese, and Russian. SWP and SW, in combination with TrueTEX, support international typesetting with the Lambda system.

Computation
Complex computational capability makes SWP and SNB indispensable tools.
Compute with MuPAD. In SWP and SNB, compute right in your document with
the MuPAD computer algebra engine.
Use enhanced MuPAD capabilities. The new MuPAD kernel is an upgrade from
the MuPAD 2.0 kernel included in Version 4.0. New features include improved 2D
and 3D plotting, expanded ODE capabilities, an expanded Rewrite submenu, and an
improved Simplify operation.
Compute with MathType mathematics in RTF les. If you open an RTF le containing MathType equations, the program converts the equations to LATEX. In SWP
and SNB, you can compute with the mathematics just like any other mathematics in
your documents.
Use an improved Exam Builder. The Version 5 Exam Builder is fully functional
with MuPAD. Printed quizzes can be reloaded without losing their math de nitions,
just like other documents. Exam Builder materials generated with earlier versions
using either Maple or MuPAD work successfully in Version 5.

Understanding the Logical Design Approach
The most important feature of the program and the key to our software approach is the
separation of content and appearance. The content of your work results from the creative
process of writing—forming ideas and putting them into words. The appearance of your

4

Chapter 1 Tools for Scienti c Creativity
work results from the mechanical process of formatting—displaying the document on
the screen and on the printed page in the most readable way.
Our approach, which is known as logical design, separates the creative process of
writing from the mechanical process of formatting. Logical design frees you to focus
on the content instead of its format. It results in increased productivity and a more
consistent, higher-quality document appearance. Logical design is different from the
approach used by many other word processors. That approach, known as visual design
(or sometimes WYSIWYG, for What You See Is What You Get), focuses on making the
screen look as much like the printed page as possible. If you've used only visual systems
before now, you may at rst be surprised by the differences between the two approaches.
One major difference is in document formatting. When you use a visual system, you
constantly apply commands that affect the appearance of the content—you select text
and then choose a font, a font size, or a typeface, or you apply alignment commands
such as center, left justify, or right justify. To center a title or an equation, for example,
you select it and choose the center alignment.
When you use a logical system, you focus on how the content relates logically to
other parts of the document rather than on the appearance of the content. Commands that
de ne the logical structure of the content replace commands that de ne its appearance.
Thus, instead of applying a centering command to create a centered title, you apply a
title tag to the title information. The properties of the tag you use determine the format
and alignment of the title.
In SNB, tag properties are determined by the style, a collection of commands that
de ne the way the document appears when you display it on the screen and when you
produce it without typesetting. In SWP and SW, tag properties are determined in two
ways: by the style and by the document's typesetting speci cations—a collection of
commands that de ne the way the document appears when you produce it with LATEX or
PDF LATEX typesetting.
Another difference between visual and logical systems is in the display of page divisions. On the screen, visual systems divide documents into pages according to their
anticipated appearance in print. To see an entire line, you often have to scroll horizontally because the screen dimensions and page dimensions do not match. In a logical
system, working with pages is unnecessary, because the division of a document into
pages has no connection to the document's logical structure. Thus, on the screen the
program breaks lines to t the window. If you resize the window, the program reshapes
the text to t it. The program displays page divisions when you preview the document.
Separating the processes of creating and formatting a document combines the best of
the online and print worlds. You do the work of creating a good document; the program
does the work of creating a beautiful one.

Using This Booklet
This brief guide to Version 5 of SWP, SW, and SNB explains how to install and register
the software. It describes how to open, close, save, and manage documents on your local
system, and how to create documents for and connect to the wider world of information
available on the Internet. The booklet explains the basics of using the program to enter,
format, edit, preview, and print text and mathematics. It also provides a series of stepby-step examples illustrating how to perform basic mathematical computations and plot

Installing and Licensing the Program
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mathematical expressions in SWP and SNB. It brie y discusses using the Exam Builder
to create algorithmically generated exams and quizzes. Finally, the booklet explains
how to use the built-in power of LATEX with SWP and SW when you need to produce a
document with a nely typeset appearance.

Making Sure You Have What You Need
Before you attempt to install and use Version 5, make sure your personal computer or
network client computer meets the hardware and software requirements shown below:
System Requirements
Available disk space
Windows XP, 2000, NT,
Me, 98, or 95**
CD-ROM drive

SWP or SW
85–300 MB*

SNB
35–200 MB**

SV
5–35 MB*

* Depending on the type of hard drive and installation options
** Windows Me, 98, and 95 require Windows Multilanguage Support

Installing and Licensing the Program
Important Before you open the product package, please read the license agreement
that accompanies the software. By installing and using the product, you accept the terms
of this agreement.
SWP, SW, and SNB are available on CD-ROM. Please remember that you may make
copies of the software only for your personal use. SV is available from the MacKichan
Software, Inc. website at http://www.mackichan.com or on CD.
Installation is a two-step process: installing the program les and registering to obtain a license. To install the program and its related les, you must run the installation
program, which is supplied on the CD-ROM and with the downloaded program. The installation program decompresses the les and copies them to your hard disk or network,
then automatically launches the registration process. You can register conveniently at
that time or wait until later. At either time, you can obtain your license from an automated Web service or by email, fax, telephone, or letter. We recommend that you use
the Web service.
You must register to activate all the capabilities and features of the program you
have purchased. Until you have obtained your license, you can use only those program
capabilities that are provided with SV, which doesn't require a license. You must have a
serial number to obtain your license; the number is provided with SWP, SW, and SNB.
Unless you're installing SV, which doesn't need a serial number, be sure you have your
serial number handy before you begin the installation. If you don't have a serial number,
you can continue to use the product in SV mode free of charge.
Follow the instructions on page 6 to install and license the program on your personal
computer. Installation and licensing procedures for networks vary depending on your
purchase arrangement. You must have administrative privileges to perform network
installation and licensing; see your system administrator for more information.
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I To install and license the program on a Windows computer
1. Start Windows.
2. If you're installing the program from a CD-ROM, insert the CD-ROM into your CDROM drive. Normally, the installation program starts automatically. If it doesn't,
a. From the Windows Start menu, choose Run.
b. Choose Browse and select the setup.exe program on the CD.
c. Choose OK.
3. If you're installing the program from a downloaded le,
a. From the Windows Start menu, choose Run.
b. Choose Browse and select the .exe program you downloaded.
c. Choose OK.
4. Follow the instructions on the screen while the program is installed on your hard
disk.
5. When the installation program asks whether you want to register your program,
Choose Yes to register now and open the registration program, then continue
these instructions.
or
Choose No to complete the installation without registering and, when prompted,
restart your computer.
To register at a later date,
i Start the program.
ii From the Help menu, choose Register.
iii Continue with these instructions, beginning with step 6.
6. If you want to register via the automated Web service,
a. From the Register dialog box, choose By an automated web service and then
choose Next.
b. Enter the serial number for your program and for any additional dictionaries that
you have purchased.
c. Enter your email address.
Other information is optional.
d. Choose OK.
e. Click OK to accept the MacKichan Software license agreement.
f. If you aren't already connected to the Internet, dial up your Internet connection.
g. Choose Register Now.
The program displays a message that your license has been received and saved.
h. Choose Finish.
i. Choose OK to close and restart the program.
or

Exploring the Program
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If you want to register via a different method,
a. From the Register dialog box, choose the method you want and then choose Next.
b. Follow the instructions on the screen to enter your serial number and other required
information and to accept the license agreement.
c. When you receive your license, follow the accompanying instructions to install it.
7. When the program asks whether you want to restart your computer, choose Yes.

Exploring the Program
On rst starting the program, you see a screen with buttons and toolbars similar to these:

The menus in the Menu bar
contain the program commands.

The insertion point in the entry area
shows where the program enters text
and mathematics or performs operations.

The buttons on the Standard toolbar
change from text to mathematics and
invoke file, editing, and screen display
commands. Many other toolbars are
available.

The popup lists in the Tag toolbar provide item, body/section, and text tags.

The screen displays a Welcome document that contains valuable information about the
program. Please read the Welcome document, then take a minute to try out the program.
You'll see just how easy it is to work with text and mathematics.

Start a New Document
Open a new document with an empty page.
1. Click

.

2. If you're using SNB or SV,
a. From the Shell Directories list, choose General.
b. From the Shell Files list, choose Blank Document.
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c. Choose OK.
d. If you're using SV, choose OK to open an editing window.
or
If you're using SWP or SW,
a. From the Shell Directories list, choose Standard LaTeX.
b. From the Shell Files list, choose Blank - Standard LaTeX Article.
c. Choose OK.
3. Display several toolbars:
a. From the View menu, choose Toolbars.
b. Check Math Templates and Editing to display the toolbars.
c. If you're using SWP or SNB, also check Compute.
d. Choose Close.

Enter Text and Math
You can use natural mathematical notation to enter an expression. The program correctly
interprets your mathematics, which appears in red on your screen by default.
1. Type To integrate and press the spacebar.
2. Click

to change from text to mathematics.

3. Type x, click
4. Click

, type 2, and press the spacebar.

to change back to text.

5. Press the spacebar; then type in SWP, enter and press the spacebar.
6. Click

.

Note that the program changes to math automatically because it recognizes that
mathematics.
7. Type x, click

, type 2, press the spacebar, and then type dx.

On your screen, you should see this:
R
To integrate x2 in SWP, enter x2 dx

R

is

Exploring the Program
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Change the Screen Appearance of Text
You can change the screen appearance of your document by changing the tags, or formatting instructions, applied to the content. By applying tags, you can emphasize a
portion of text, such as by making it bold, italic, or large, and you can create headings,
centered text, and lists.
1. Highlight SWP in the expression you have entered.
2. Click

.

or
Click the Text tag box on the Tag toolbar at the bottom of the screen:

and then on the list of tags displayed, click Bold.
The program changes the selected text to boldface.
3. Place the insertion point anywhere in the expression.
4. Click the Section/Body tag box at the bottom of the screen and click Centered.

Now your expression is centered:
To integrate x2 in SWP, enter

R

x2 dx

For fast tag application, you can assign tags to function keys from the Tag menu.

Compute
In SWP or SNB, you can perform complex computations in your document.
R
1. Place the insertion point at the end of the expression x2 dx.
2. Click

to evaluate the expression.

The computational engine performs the integration (a special pointer shows while
the computation is in progress) and places the calculated value in your document:
To integrate x2 in SWP, enter

R

x2 dx = 31 x3
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Plot Mathematics
With SWP and SNB, you can plot the values you compute, and then add values to those
plots, all without leaving your document.
R
1. With the insertion point to the right of the expression x2 dx = 13 x3 , click
.
The computational engine plots your mathematics:
y 40
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-10

5
x

-20
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-40

2. Now see how easy it is to add to the plot:
a. In your expression, select x2 .
b. Hold down the mouse button and drag the selection to the plot, making sure the
pointer is inside the plot border, and then release the mouse button. The graph is
replotted, so that you now see this:
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Print the Document
When you print your document, your output looks like what you see on the screen. (In
SWP and SW, you can also choose to typeset your document with LATEX or PDFLATEX.
See Chapter 4 “Typesetting Your Document” for more information.)

Exploring the Program
1. Click
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.

2. In the Print dialog box, select the printer you want to use, and then choose OK.

Browse the Internet
If you have Internet access, you can go directly to any Internet location that has a Uniform Resource Locator (URL) without ever leaving your document. For example, you
can visit our website, where you can nd even more information about the program.
1. Click

.

2. Enter http://www.mackichan.com and choose Open.
You can specify any URL on the Web. If the location you speci ed isn't a .tex or
.rap document created in SWP, SW, or SNB, the program activates the appropriate
program on your computer, such as your Web browser or PDF viewer. Your document
remains open. Any SWP, SW, or SNB documents that are available on the Internet are
opened as read-only documents.

Save and Close the Document
Save and close your document, unless you are using SV.
1. Click

.

2. Type a name for the document and choose OK.
3. From the File menu, choose Close.

Leave the Program
You can leave the program several ways. If you haven't saved your SWP, SW, or SNB
document, the program prompts you to save your work.
From the File menu, choose Exit.
or
Press ALT +F4 (that is, hold down the ALT key and press F4).
or
At the top right corner of the program window, click the Close button
or

.

At the top left corner of the program window, double-click the program icon, or click
the icon once and then choose Close.

2

Learning the Basics

SWP, SW, and SNB are intuitive. Whether you're writing text or mathematics, you'll
nd that using the program is easy.

Using the Workplace
The program window is your workplace. Take a moment to familiarize yourself with the
window, its menus, and some commonly used toolbars (shown below). Remember that
not all toolbars appear for all products.
Title bar

Menu bar

Compute toolbar

History toolbar

Math
Templates

Standard
toolbar

Symbol Cache

Stop toolbar

Insertion point

Typeset toolbar

Program window

Document window

Remove Item Tag button

Status bar

Tag toolbar

Fragments toolbar

The toolbar buttons are identical in function to many of the menu commands. Brie y
point the mouse at each button to display a tooltip identifying the button and its function.
The Standard toolbar contains buttons for the most frequently used commands on the
File and Edit menus:
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New

Save

Open

Print

Open
Location

Spelling

Preview

Copy

Cut

Undo

Paste

Show/Hide
Nonprinting Table

Properties

Toggle
Text/Math

Zoom Factor

Other toolbars are available from the View menu.
I To display or hide a toolbar
1. From the View menu, choose Toolbars.
2. In the Toolbars dialog box, check the box next to each toolbar you want to display,
and uncheck the box next to each toolbar that you want to hide.
3. Choose Close.

Opening a Document
Starting the program automatically opens a blank document, which is a shell, or template, for a typical new document. If you want to produce a similar document, you can
begin entering information right away. If you want to create some other kind of document, open a new le and choose a different kind of shell. Each shell is different.
Explore a little to see what's available.
I To open a new document
1. On the Standard toolbar, click

or, from the File menu, choose New.

2. From the Shell Directories list, choose the kind of document you want.
3. From the Shell Files list, choose the shell you want for your document.
4. Choose OK.
Instead of opening a new document, you may want to open a document that already
exists.
I To open an existing document
1. On the Standard toolbar, click

or, from the File menu, choose Open.

2. Choose the le folder and name of the existing document.
3. Choose Open.

Entering and Editing Text
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Entering and Editing Text
Entering information is straightforward, whether you prefer the keyboard or the mouse.
You use standard editing tools to revise your document.

Entering Text
Unless you tell it otherwise, the program assumes that everything you type is text. When
you're entering text, the Math/Text toggle on the Standard toolbar appears as

.

I To enter text, just start typing.
Although most keyboards don't contain special text characters, you can enter many
of them from the panels available when you display the Symbol Panels toolbar:
Lowercase Binary
Negated Miscellaneous
General
Greek Operations Relations Symbols Latin-1 Punctuation

Uppercase Binary Arrows Special
Latin
Greek Relations
Delimiters Extended-A

I To enter special characters
1. From the View menu, choose Toolbars, check Symbol Panels, and choose Close
to display the toolbar.
2. Click one of the buttons on the toolbar to display a panel of special characters. Most
special text characters appear on the Greek, Latin-1, Latin Extended-A, or General
Punctuation panels. Open the panels to view the available characters.
3. Click the character you want.
You can copy the special characters you use most often to the Symbol Cache toolbar;
see page 35.
I To place information in a table
1. On the Standard toolbar, click

or, from the Insert menu, choose Table.

2. Set the number of rows and columns in the table. You can also change the alignment
of the columns and the alignment of the table in relation to the text baseline.
3. Choose OK.
4. Fill your table with information, moving from cell to cell with the TAB key.
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Editing Text
Once you've entered your text, you may need to edit it. You can use standard clipboard
and drag-and-drop operations to cut, copy, paste, and delete selections. If you change
your mind, you can undo the most recent change or deletion. To help revise your content,
you can also use the spell check feature available from the Tools menu or the Standard
toolbar, and the nd and replace feature, available from the Edit menu or the Editing
toolbar.
I To undo your most recent change or deletion
On the Standard toolbar, click

or, from the Edit menu, choose Undo.

Another way to edit text is by changing the properties of individual characters. For
example, you might add an accent to a character so that a becomes ä.
I To edit the properties of a character
1. Select the character or place the insertion point to its right.
2. Open the Character Properties dialog box:
On the Standard toolbar, click
.
or
From the Edit menu, choose Properties.
or
Press CTRL +F5 (hold down the CTRL key and press F5).
or
Click the right mouse button or press the Application key
Context menu and then choose Properties.

to open the

3. Make the changes you want, and then choose OK.

Entering and Editing Mathematics
Because the program assumes you're entering text, you must tell it when you want to
enter mathematics. Then, you can enter mathematics easily using the toolbar buttons,
Insert menu commands, or keyboard shortcuts.
I To start mathematics
On the Standard toolbar, click

or, from the Insert menu, choose Math.

When mathematics is active, the Math/Text toggle appears as

.

I To return to text
On the Standard toolbar, click

or, from the Insert menu, choose Text.

When text is active, the Math/Text toggle appears as

.
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Entering Mathematical Characters
Mathematical characters and symbols are available from the customizable Symbol Cache
toolbar and the symbol panels. We suggest you open the symbol panels one by one to
explore all the available characters. Choosing a mathematical character automatically
starts mathematics, even if you have not toggled to mathematics.
I To enter a mathematical character
1. From the View menu, display the Symbol Cache and Symbol Panels toolbars.
2. Click the character you want from the Symbol Cache toolbar:

or
Click one of the buttons on the Symbol Panels toolbar to open a panel of special
characters, and then click the character you want.

Entering Mathematical Objects
Mathematical objects such as fractions, radicals, subscripts, superscripts, operators, and
brackets are available from the Insert menu and the Math toolbars. Many mathematical
objects can be entered with keyboard shortcuts (see Appendix B).
Fraction Superscript Parentheses Sum

Radical

Subscript

Square
Brackets

Unit
Name

Integral

Big
Operators Matrix Binomial Decoration

Display

Math Templates

Brackets

Math
Name

Label

Math Objects

When you enter a mathematical object, the program automatically starts mathematics
and places a template for the object in the document. You ll in the template to complete
the object. The instructions below explain how to enter some common mathematical
objects and how to create in-line and displayed mathematics. Be sure the math toolbars
are displayed. Appendix B contains shortcuts that make entering mathematics even
faster.
I To enter a fraction
1. On the Math Templates toolbar, click
tion, or press CTRL + F.
On the screen, you see

or, from the Insert menu, choose Frac-

, and the Math/Text toggle changes to

2. Type the numerator, and then press TAB .
3. Type the denominator, and then press the spacebar.

.
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I To enter a superscript or subscript
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type a variable.
3. On the Math Templates toolbar, click
superscript.

or press

CTRL + UP ARROW

to enter a

or
On the Math Templates toolbar, click
a subscript.

or press CTRL + DOWN

ARROW

to enter

4. Type the superscript or subscript, and then press the spacebar.
I To enter an expression in parentheses
1. On the Math Templates toolbar, click

.

2. Type the expression. Notice that the parentheses are elastic—they expand horizontally and vertically as far as necessary to enclose the expression you enter.
3. Press the spacebar.
I To enter a matrix
1. On the Math Objects toolbar, click

or, from the Insert menu, choose Matrix.

2. Set the number of rows and columns, the alignment, and the baseline of the matrix.
3. Choose the delimiters for the matrix, if desired.
4. Choose OK.
5. Fill your matrix with mathematics, moving from cell to cell with the TAB key.
6. Press the spacebar to leave the matrix.
I To enter an operator
1. On the Math Objects toolbar, click
tor.

or, from the Insert menu, choose Opera-

2. Double-click the operator you want.
3. On the Math Templates toolbar, click
operator.

and then type the lower limit for the
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4. Press TAB, and then type the upper limit.
5. Press the spacebar, and then type the variable.
6. If the variable carries a subscript, click
spacebar.

, type the subscript, and then press the

If the expression
is in a line of text, the limits are automatically placed to the right,
Pn
like this:
a
.
i=1 i If the expression is displayed on a line by itself, the limits are
automatically placed above and below the operator:
n
X
ai
i=1

I To change in-line mathematics to displayed mathematics
1. Enter a mathematical expression, and then select it.
2. On the Math Objects toolbar, click

.

I To change displayed mathematics to in-line mathematics
Place the insertion point to the right of the display and press BACKSPACE .

Entering Mathematics with Fragments
If you enter a certain expression or equation frequently, you can save it as a fragment
and then enter it in any document with just a few keystrokes. Fragments are available
from the File menu and from the popup list on the Fragments toolbar:

You can save both mathematics and text in a fragment.
I To enter a fragment in your document
Press ALT +4 or click the Fragments popup to display the list of available fragments,
and then click the name of the fragment you want or use the arrow keys to select the
fragment and then press ENTER .
or
From the File menu, choose Import Fragment, select the fragment you want, and
then choose Open.
I To save an expression as a fragment
1. Select the expression or equation you want to save as a fragment.
2. On the Fragments toolbar, click
ment.

or, from the File menu, choose Save Frag-
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3. Type a le name to be used to recall the fragment. Avoid using the name of a TEX
command for the fragment. If you leave the directory unchanged, your fragment will
appear in the top part of the list of available fragments. You can create subdirectories
for fragments.
4. Choose Save.

Using Body Math
You can enter a series of mathematical expressions quickly if you enter them in a Body
Math paragraph. The Body Math tag is available from the Section/Body Tag popup
list. Each time you press ENTER in a Body Math paragraph, the program automatically
switches to mathematics. This makes it easy to use your document as a mathematics
scratchpad. See Formatting with Tags on page 21.

Editing Mathematics
When you need to edit your mathematics, you can use standard clipboard and dragand-drop operations to cut, copy, paste, and delete. You can also edit the properties of
mathematical characters, symbols, and objects.
When you edit the properties of a mathematical character or symbol, the program
opens the Character Properties dialog box. When you edit the properties of a mathematical object, the program opens a context-sensitive dialog box; that is, a dialog box
that corresponds to the mathematical object you've selected. If you haven't selected an
object, the program opens the dialog box appropriate for the object to the left of the
insertion point.
I To edit the properties of a mathematical object
1. Select the object or place the insertion point to its right.
2. Open a context-sensitive Properties dialog box:
Click
.
or
From the Edit or Context menu, choose Properties.
or
Press CTRL+F5.
3. Make the changes you want, and then choose OK.

Formatting Your Document
In SWP, SW, and SNB, you can produce your document without typesetting it. In
SWP and SW, you can also typeset your document. The appearance of your document
depends on which method you use.
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If you display your document in the document window or produce it without typesetting, the program formats the document using the document style (.cst) le, the
page setup speci cations, and the Document Info print options.
If you typeset your document, the program formats the document using the typesetting speci cations, including the document class options, any LATEX package options,
and any TEX commands that have been added to the document. Chapter 4 “Typesetting Your Document” has more information.

Formatting with Tags
Both the document style and the typesetting speci cations de ne tags—collections of
formatting and behavior properties that determine the appearance of your document. The
properties de ne the type face, font size, font style, paragraph indention, justi cation,
and many other aspects of document appearance. When you apply a tag to information in
your document, the program applies the formatting and behavior properties associated
with the tag to that information. Using tags, you can create a consistent appearance
throughout your document without having to format each element individually.
Tag properties are de ned in the style le for the shell you used to create your document. In SWP and SW, tag properties are also de ned in the typesetting speci cations
for the shell. In SWP and SW, the way you produce your document determines which
set of properties the program uses.
The program has section/body tags, item tags, and text tags. Everything you enter
in your document carries one or more tags. The program automatically applies the
Body Text tag to all text that you enter. By changing the Body Text tag to a different
section/body tag, you can create a heading or a centered paragraph, and by adding an
item tag, you can create a list.
In addition to applying tags from the popup lists at the bottom of the program window, as described in these instructions, you can apply tags with the function keys and
with the Apply command on the Tag menu.
I To enter a heading
1. Press ALT +2 or click the Section/Body Tag popup list:

2. From the tag list that pops up, click the heading level you want.
3. Type the text of the heading and then press ENTER .
I To center text
1. Press ALT +2 or click the Section/Body Tag popup list.
2. From the tag list that pops up, click the centering tag you want.
3. Type the text to be centered and then press ENTER .
4. Click the Section/Body Tag popup list again and click the Body Text tag.
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I To enter a list
1. Press ALT +1 or click the Item Tag popup list:

2. From the tag list that pops up, click the type of list you want.
3. Type the rst item in the list and press ENTER . Repeat for each item in the list.
4. To complete the list, click the Remove Item Tag button

or press F2.

With text tags, you can emphasize a text selection. For example, you might want
to make a selection appear Bigger, Smaller, Italic, Bold, or Strongly Emphasized.
Depending on the text tags available in the document style, your text might appear as
Typewriter text, Sample Text, or K EYBOARD I NPUT.
You can apply four frequently used text tags (Normal, Bold, Italic, and Emphasized)
with the corresponding

,

,

, and

buttons on the Editing toolbar.

I To emphasize a portion of text
1. Select the text you want to emphasize or, if you haven't typed the text, place the
insertion point where you want the emphasis to begin.
2. Click

,

, or

to choose Bold, Italic, or Emphasized.

or
Press ALT +3 or click the Text Tag popup list:

and from the tag list that pops up, click the text tag you want.
3. If you haven't yet typed the text, type it and then click

to turn off the emphasis.

Changing the Appearance of Your Document
All formatting speci cations are initially de ned by the shell with which your document
was created, but you can modify them. You can modify the style (.cst) le to change
the appearance of your document when you display it or produce it without typesetting.
Style modi cations can apply during the current editing session only, or they can apply
globally for all documents created with the same style le. You can also create a new
style to produce documents that t speci c formatting requirements.
Changing the typesetting speci cations is more complex. You can make some modications to the typesetting speci cations by changing the document class options and the
options for LATEX packages used with your document, and you can add TEX commands

Formatting Your Document

23

to the preamble, front matter, and body of the document. However, extensive modi cation of the typesetting speci cations isn't advisable and requires a knowledge of TEX
and LATEX. Please see Chapter 4 “Typesetting Your Document” for more information
about changing the typesetting speci cations.
Modifying the Tag Properties De ned in the Style
You can change the way tagged text appears in the document window and when you
produce it without typesetting if you modify the tag properties de ned in the style (.cst)
le for the document shell. Tag properties have some subtle characteristics.
Basic properties. Tag properties de ne the appearance of tagged text in terms of the
tag type font; the spacing, background color, and indention of tagged paragraphs;
the color and size of mathematics and mathematical objects that occur in tagged
text; and the behavior of the tag. Tag properties also de ne the appearance of special
objects (such as citations, lead-in objects, tables, and mathematical displays) when
they occur within tagged text.
Nested properties. Tags can be nested and so can their properties. The style determines the properties to use beginning with the innermost tag.
Inherited properties. Rather than specifying a value for a tag property, the style can
specify that the property inherit its values from the surrounding text.
Unspeci ed properties. If the style doesn't de ne a speci c or inherited value for
a particular tag property, the style uses the corresponding property value for the
surrounding tag.
Default properties. When no other properties apply in a given context, the style
uses default properties.
Examples illustrating these characteristics appear in the online Help.
I To change the screen appearance of tagged text
1. On the Editing toolbar, click
or, from the Tag menu, choose Appearance to
open the Tag Appearance dialog box.

2. In the Tags list, select the tag whose screen appearance you want to change.
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3. In the Tag Properties area, select the property and, if necessary, the special object
that you want to change, and then choose Modify.
In addition to many others, these properties are available for most tags:
Choose
Font
Paragraph
Behavior
Math
Special Objects

To modify the appearance of
Type face, size, style, and color
Justi cation, indention, line spacing, background color
Tag for the following paragraph; appearance of the
tag name in popup lists
Screen color, size, and placement of mathematical objects
Citations, lead-in objects, tables, matrices, displays,
graphic and plot captions, formulas, input buttons,
hypertext links, hypertext markers, and cross-references

4. Make the changes you want in the property dialog box and then choose OK.
5. Repeat steps 2-4 for all tags whose style properties you want to change.
6. If you decide you don't want the changes for a particular tag property,
a. Select the tag.
b. Select the property in the Tag Properties area.
c. Choose Revert to Previous.
7. If you decide you don't want any of the tag property changes, choose Restore Original Style to return to the settings saved in the style le.
8. Save the changes:
Choose Save to save the changes to the current style le, which is listed in the
box labeled Style File for Document. This will alter the screen appearance of
all documents created with the style.
or
Choose Save As to save the settings in a new style le. Enter a name for the new
le and choose Save.
9. Choose OK.
Adding Tags
You can create a new body or text tag by cloning, or copying, an existing tag and then
modifying the new tag as necessary. Item tags and section tags can't be cloned.
I To clone a tag
1. In the Tags list, select the body or text tag you want to clone and choose Clone Tag.
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2. Enter a name for the new tag and choose OK.
The program displays the name in the Tags list and in the corresponding tag popup
list in the program window.
3. In the Tags list, select the new tag.
4. Select and modify the tag properties as necessary, and then choose OK.
5. Save the changes in the same style (.cst) le or as a new style.

Formatting the Page
If you produce your document without typesetting it, the margins, headers, footers, and
page numbers are set initially by the page setup speci cations for the document shell.
Margins, headers, footers, and page numbers don't appear in the document window, but
you can see them when you preview. You can change them to suit your needs.
I To modify the page setup speci cations
1. From the File menu, choose Page Setup.
2. Choose the tab you need:
Choose
Margins
Headers/Footers
Counters

To
Set the left, right, top, and bottom page margins
Specify headers, footers, and page numbering
Specify the page numbering style

3. Make the necessary modi cations.
4. Choose OK.
Remember that if you typeset your document in SWP or SW, the program ignores
the page setup speci cations, and sets the margins, headers, footers, and page numbers
according to the typesetting speci cations.

Working with Hypertext Links
You can use hypertext links, or jumps, to link your document to information in another
location. You can access information located elsewhere in the same document, in other
documents on the current system or network, or, if you have Internet access, on the Web.
See Browsing the Internet on page 31 for more information.

Creating Hypertext Links
Hypertext links have two parts: the link and the target. The link creates a pointer to the
target and de nes the appearance of the pointer in your document. (Read more about
hypertext links and typesetting in Creating Documents with Scienti c WorkPlace and
Scienti c Word and in the online Help.)
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The target of a hypertext jump can be any object to which you've assigned an identifying key or marker—such as a gure, a section, or equation—or any le, including
les on the Internet. The address of the target differs depending on the target itself and
follows the model used in standard Web browsers.
I To create a hypertext link
1. Place the insertion point where you want the link to appear.
2. On the Field toolbar, click

or, from the Insert menu, choose Hypertext Link.

3. In the Hypertext Link dialog box, enter the screen text for the link. The screen text
can contain a graphic.
See the online Help for information about printing documents containing hypertext
links.
4. In the Target box, enter the address of the target:
If the target is outside the current document, enter the document address in the
URL box, and the marker, if any, in the Marker box.
If the target is inside the current document, enter the marker in the Marker box.
5. Choose OK.
I To create a marker in a document
1. Open the target document and place the insertion point where you want the marker.
2. On the Field toolbar, click

or, from the Insert menu, choose Marker.

3. In the Key box, enter a unique key for the item and choose OK.
4. Save the document.

Jumping with Hypertext Links
By default, hypertext links appear in color in the program window. Any time you encounter a link in a document, you can jump immediately to the linked information,
whether that information is in the same document, in other documents on the current
system or network, or, if you have Internet access, on the Web.
I To jump to the target of a hypertext link
1. Place the insertion point in the link so that the hypertext pointer
2. From the Tools menu, choose Action.
or

appears.

Saving Your Document

27

Press CTRL while you click the link.
or
If the link appears in a document saved as read-only (such as those provided with the
program), click the link.
The program moves the insertion point to the speci ed location, opening speci ed
documents or linking to the Internet as necessary.

Saving Your Document
When you've nished writing, save your document.
I To save your document
1. On the Standard toolbar, click

or, from the File menu, choose Save.

2. Type a name for your document.
Any le name compatible with your Windows system is acceptable. The name cannot include the following characters: * ? n / : j < > $ ^.

Note If the name includes characters that have special meaning to TEX, such as a
space or ~, you won't be able to typeset your document in SWP or SW.

3. Choose OK.
The program saves your document as a .tex le.

Saving Portable LATEX Files
If you're working in SWP or SW, you can save your document using the Portable LATEX
output lter. This lter creates documents that have a .tex extension but are more easily
read by standard LATEX installations. When you output a document as a Portable LATEX
le, the program doesn't include the special set of macros called tcilatex in your
document (the line ninput{tcilatex} doesn't appear in the document preamble),
nor does it include any LATEX packages that aren't part of a standard LATEX installation.
Graphics and mathematics plots are exported as graphics; you can select the export
format you prefer. Portable LATEX is unavailable in SNB, for Style Editor styles, and for
styles created under LATEX 2.09.
I To save your document as a Portable LATEX le
1. If you want to change the export settings for graphics and mathematics plots,
a. From the Typeset menu, chose General Settings.
b. Choose Portable LaTeX Graphics Settings.
c. Change the graphics export settings as necessary, then choose OK to close the
dialog boxes and return to your document.
2. From the File menu, choose Save As.
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3. Type the name and location of the le.
4. In the Save as type area, select Portable LaTeX (*.tex) and choose Save.

Exporting Files
You can export your document in several formats, including Rich Text Format (RTF)
and HTML (see page 30). Saving and exporting differ. If you save the le, the program
creates and opens a new le, then closes your original le. If you export the le, the
program creates the le but doesn't open it, and leaves your original document open.
When you export your document as an RTF le, the program preserves the formatting you see in the document window. Any mathematics in your document can be represented with MathType 3 (Equation Editor) or MathType 5 objects, depending on the
selections you make for RTF exports in the Export Settings dialog box. The resulting
RTF le can be viewed in another program, such as Microsoft Word, even if an Equation
Editor is not part of the Word installation. If the Microsoft Word installation includes
the appropriate Equation Editor, the MathType 3 or MathType 5 objects can be edited.
I To export your document as an RTF le
1. If you want to change the RTF export settings,
a. Choose Export Settings and choose the RTF Document Export Options tab.
b. Change the settings as necessary and choose OK.
2. From the File menu, choose Export Document.
3. Type the name of the le.
4. In the Save as type area, select RTF Document (*.rtf).
5. Choose Save.
Note that RTF documents that contain many mathematical objects can load slowly
in Microsoft Word. If you need to stop the process, press ESC . You may want to split
math-intensive documents into several smaller documents before exporting them as RTF
les.

Previewing and Printing Your Document
You can print documents from the document window or the preview window. For information about typesetting, see Chapter 4 “Typesetting Your Document.”
I To preview a document
1. On the Standard toolbar, click

or, from the File menu, choose Preview.

2. Use the scroll bars and the toolbar buttons to examine your document in the preview
window.
3. When you're ready to leave the previewer, click the Close button.
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I To print a document
1. From the Standard toolbar in the document window, click
menu, choose Print, or press CTRL + P.

or, from the File

or
From the Menu bar of the preview window, choose Print.
2. Specify the printer and the print options you want and then choose OK.
The program uses the same routines to preview and print your document as it does to
display it in the document window. Therefore, what you see when you preview or print
your document without typesetting it resembles what you see when you display it, except that margins, headers, footers, and page numbers aren't displayed in the document
window.
You can set the zoom factor for printing your document from 50% to 400% of the
normal size. This feature doesn't apply to typesetting.
I To change the zoom factor for printing
1. From the File menu, choose Document Info.
2. Choose the Print Options tab.
3. Set the zoom factor you want and choose OK.

Working on the Web
With Version 5 of SWP and SW, you can create typeset PDF les that can be read
by PDF viewers such as Acrobat Reader. You can also export your .tex documents
as HTML les or place them directly on the web as .tex or .rap les. Without ever
leaving your document, you can activate your Web browser or PDF viewer to open URLs
on the Web.

Creating PDF Files
In Version 5 of SWP and SW, you can create beautifully typeset PDF les. SWP and
SW include PDFTEX, a system based on TEX, that produces PDF les instead of DVI
les. No additional software is necessary to create PDF les from your SWP and SW
documents; you need a PDF viewer to preview and print the les.
The PDFTEX system uses PDFLATEX to create fully typeset les. All cross-references
and other document elements that are generated automatically by LATEX are preserved.
Fonts and graphics are automatically embedded in the resulting PDF le. If you add
the hyperref package to your document, PDFLATEX converts any cross-references in
your document to hypertext links in the PDF le and also creates links from the table
of contents to the corresponding sections of the le. Your document looks the same
whether you typeset it with PDFLATEX or with LATEX. See Chapter 4 “Typesetting Your
Document” for more information about typesetting.
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I To create a PDF le
1. Create an SWP or SW document.
2. From the Typeset menu, choose Output Choice.
3. Select PDF output or Both DVI and PDF output and choose OK.
You can also change the way graphics and mathematics plots are exported. See the
online Help and Creating Documents with Scienti c WorkPlace and Scienti c Word
for more information.
4. From the Typeset menu, choose Preview PDF or Print PDF.
Your PDF viewer displays the typeset PDF le or sends it to the printer.

Exporting Documents as HTML Files
The HTML export lter provides a fast way to create accurate HTML versions of your
documents. The les can be viewed with recent versions of the most popular browsers
and may also be readable by word processors that can't read LATEX. When you export
a document as an HTML le, the lter exports graphics in a default format, which you
can change. It also converts any instances of mathematics or mathematics plots in your
document to graphics les in a default format. The mathematics are not “live” and you
can't perform computations with them. As an option, you can export any mathematics
as MathML. However, not all HTML browsers support MathML. You can insert HTML
commands in elds in your document; the HTML lter passes them to your browser.
See Creating Documents with Scienti c WorkPlace and Scienti c Word for more information.
Because the HTML lter ignores cross-references and other document elements that
are generated automatically by LATEX, you should develop the document without regard
for its typeset form and appearance. By default, the lter creates a Cascading Style Sheet
(.css le) that re ects the style (.cst) le for your document.
I To export a document as an HTML le
1. Format your document so that its appearance in the document window is as you want
it to appear online.
2. If you want to change the export settings for mathematics, graphics, and mathematics
plots,
a. Choose Export Settings and choose the HTML Document Export Options tab.
b. Change the mathematics export settings as necessary.
c. If you want to change the graphics export settings, choose Graphics Settings,
make the changes you need, and choose OK.
d. Choose OK.
3. From the File menu, choose Export Document.
4. Enter a location and a name for the document.
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5. In the box labeled Save as type, specify the format you want.
6. Choose Save.

Using TEX Files on the Web
You can place any .tex or .rap document created with the program on the Web. Anyone with Internet access and SWP, SW, SNB, or SV can open the document. See
Browsing the Internet, below, for information about opening Internet locations from inside the program.
SWP, SW, and SNB documents residing on the Web are opened as read-only documents in a new document window. You must save the les locally if you want to work
with information in the documents, use SWP or SW to typeset the document, or use
SWP or SNB to compute with any mathematics they contain.

Browsing the Internet
In addition to jumping to any Internet location de ned in a hypertext link, you can open
any URL on the Web from within the program.
I To open an Internet location
1. From the File menu, choose Open Location.
2. In the Open Location dialog box, enter the URL of the location you want to access.
3. Choose Open.
If the location you specify isn't a .tex or .rap document created with SWP, SW, or
SNB, the program activates the appropriate program on your system, such as your Web
browser or PDF viewer. Any open documents remain open while you browse. Program
documents with a .tex or .rap extension that are placed on the Internet are available
as read-only documents. You must save a copy of them locally if you want to use or
perform computations on any information they may contain.
I To cancel an attempt to open an Internet location
On the Stop toolbar, click

or press CTRL + BREAK .

Managing Your Documents
Documents created with SWP, SW, and SNB are associated with many les in addition
to the one that contains the document itself. Some of these les may contain graphics,
subdocuments, or style information. Others are created by the program when you typeset. Depending on the le type, the program may not store an associated le in the same
directory that holds the document le. Therefore, when you copy, delete, or rename a
document and especially when you exchange documents with colleagues, use the Document Manager to ensure that all the les associated with your document are handled
correctly.
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With the Document Manager, you can copy, delete, rename, view, or clean up a
document. Also, you can wrap or unwrap a document. That is, you can gather together
into a single text le all those les that accompany a document, or you can break a le
that has been wrapped into separate les again. Wrapping a le before you send it to
another location by email or on diskette ensures that all necessary les are sent along
with the primary document le. You can unwrap a le with SWP, SW, or SNB; the
Document Manager; or an ASCII editor.
I To start a Document Manager operation
1. From the Tools menu, choose Document Manager.
2. Choose a document.
3. Choose the operation you want.
I To wrap a document
1. From the Tools menu, choose Document Manager.
2. In the File Selection box, type the name of the document you want to wrap.
3. Choose Wrap.
4. Exclude any les you don't want to wrap with your document.
In most cases, if you're sending the document to someone who has SWP or SW,
you don't need to send standard typesetting speci cations. If you're sending the
document to someone who has SWP or SNB, you don't need to send plot snapshots.
5. Choose OK.
The Document Manager creates a .rap le with the same name as your document.
The le contains your document, the additional les you included, and instructions
for using an ASCII editor to recreate the original les, in case the recipient uses
different software.
6. When the operation is complete, choose OK and then choose Close.
You can also create a .rap le from the Export Document command on the File
menu, but the style and LATEX typesetting speci cations are not included in the resulting
le, and some wrapping options are unavailable.
I To open a wrapped document from the File menu
1. From the File menu, choose Open.
2. In the Files of type area, select Wrap (*.rap) or Wrap created by SW/SWP 2.5
(*.msg).
3. Select the name and location of the wrapped le and choose OK.
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I To unwrap a document with the Document Manager
1. From the Tools menu, choose Document Manager.
2. In the File Selection box, type the name of the document you want to unwrap or
use the Browse button to locate and select the document.
3. Choose Unwrap.
4. Select the destination folder for the les and choose OK.
5. Exclude any les you don't want to unwrap with the document and choose OK.
The Document Manager unwraps the document, placing each le in the correct directory.
6. When the operation is complete, choose OK and then choose Close.
I To unwrap a document with an ASCII editor
Open the wrapped le with the editor and follow the instructions in the le header.

Customizing the Program
The program is exible: you can customize it to suit the way you work. By modifying
the appearance of the program and document windows and the use of program tools and
defaults, you can make SWP, SW, and SNB even more convenient to use.

Changing the Appearance of the Toolbars
You can modify the program window by displaying only those toolbars and symbol
panels you use most frequently and by moving toolbars to screen locations that are
convenient for you. Additionally, you can add the symbols and characters you use most
often to the Symbol Cache toolbar.
I To display or hide toolbars
1. From the View menu, choose Toolbars.
2. Check the toolbars you want to display and uncheck the toolbars you want to hide.
3. Choose Close.
I To return to the original toolbar display
1. From the View menu, choose Toolbars.
2. Choose Reset and then choose Close.
You can dock the toolbar at the top, bottom, or sides of the program window, or you
can let it oat on your desktop or in the entry area of the program window.
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I To move a toolbar to a new location
1. Display the toolbar.
2. Place the mouse pointer anywhere in the gray area surrounding the toolbar buttons.
3. Drag the toolbar to a new location.
I To reshape a toolbar
1. Float the toolbar on the screen.
2. Place the mouse pointer on the edge of the toolbar.
The pointer changes to indicate that the toolbar can be reshaped.
3. Drag the toolbar to reshape it.
Customizing the Symbol Panels
For faster access to symbols and characters, you can leave open the symbol panels you
use most often and oat them anywhere you want.
I To oat a symbol panel on the screen
1. On the Symbol Panels toolbar, click the symbol panel you want.
2. Place the mouse pointer on the title bar of the panel.
3. Drag the panel to a new location on the screen.
You can tailor the panels to move characters and symbols to a new location or remove
characters and symbols that you don't use from the panel.
I To move a symbol on a panel
Hold down the SHIFT key, select the symbol, and drag it to a new location.
I To remove a symbol from a panel
Hold down the SHIFT key, select the symbol, and drag it off the panel.
I To restore a panel to its original con guration
Click the right mouse button in the toolbar and choose Reset to Defaults.
I To close a symbol panel
In the upper-right corner of the symbol panel, click
or

.

On the Symbol Panels toolbar, click the button for the symbol panel.
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Customizing the Symbol Cache Toolbar
You can add to the Symbol Cache toolbar as many symbols from the symbol panels as
you need and you can rearrange the symbols or remove any symbols you don't need.
I To add a symbol to the Symbol Cache toolbar
1. Open the Symbol Cache toolbar and the symbol panel containing the symbol.
2. Select the symbol and drag it to any location on the Symbol Cache toolbar.
I To rearrange the symbols on the Symbol Cache toolbar
Hold down the
toolbar.

SHIFT

key, select a symbol, and drag it to a new location on the

I To remove a symbol from the Symbol Cache toolbar
Hold down the SHIFT key, select the symbol, and drag it off the toolbar.

Changing the Appearance of the Document Windows
In addition to sizing the program window to your liking, you can customize the document windows. You can have several document windows open at the same time, and
you can arrange them conveniently within the program window. You can set the magnication and the characteristics of the view separately for each window.
I To open a document in a new window
Open an existing document:
a. On the Standard toolbar, click
or, from the File menu, choose Open.
b. Specify the le you want to open, and then choose Open.
or
Open a new document:
a. On the Standard toolbar, click
or, from the File menu, choose New.
b. From the New dialog box, choose the shell you want, and then choose OK.
or
Open another view of the active document:
From the Window menu, choose New Window.
I To arrange the open document windows
From the Window menu, choose Cascade, Tile Horizontally, or Tile Vertically.
or
With the mouse, drag the title bar of a document window to the position you want.
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You can change the magni cation of the document in each window from 50% to
400% of normal size.
I To change the magni cation in the active window
From the View menu, choose 100% or 200%; or choose Custom, set the percentage of magni cation you want, and choose OK.
or
On the Standard toolbar, click the Zoom Factor box
, and then choose
the percentage of magni cation you want or type it and press ENTER .
Note that you can set separate zoom factors for displaying and for printing the document
without typesetting.

Changing the Tools and Defaults
Working in SWP, SW, and SNB is fast and convenient, but you can make it even more
so if you set the function keys to apply the tags you use most often and set the program
defaults to customize the way the program works.
Customizing the Function Key Assignments
Initially, the function keys have these tag assignments:
Key
F2
F3
F4
F5
F6

Tag
Remove Item Tag
Body Text
Normal
Bold
Emphasize

Key
F7
F8
F9
F11
F12

Tag
Numbered List Item
Bullet List Item
Typewriter
Section
Subsection

You can set global function key assignments that apply to all documents, or you can
override the global settings with different function key assignments for each style.
I To change a function key assignment
1. From the Tag menu, choose Function Keys.
2. In the Tag Key Assignments dialog box, select the tag you want to assign to a
function key.
3. Place the insertion point in the box marked Press New Keys, and press the function
key you want to use. You can use modi ers such as CTRL , ALT, and SHIFT.
4. Choose Assign to Style or Assign Globally.
If the function key you choose is already assigned to a tag, the program clears the
old assignment.
5. Choose Close.
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I To clear a tag assignment
1. In the Tag Key Assignments dialog box, select the tag whose assignment you want
to clear.
2. In the Current Assignments box, select the assignment, and then choose Remove.
3. Choose Close.
Customizing the User Setup
By changing the User Setup defaults, you can customize the way the program works
with les, text, mathematics, and graphics. The online Help and Creating Documents
with Scienti c WorkPlace and Scienti c Word contain more information.
I To customize a program default
1. From the Tools menu, choose User Setup.
2. Choose the tab for the kind of default you want to set:
These defaults
General
Edit
Start-up Document
Graphics
Files
Math
Font Mapping/IME

Relate to
How the program operates internally
How certain keys and the mouse function as you type
Which document shell is displayed when you open the
program
How the program treats new graphics
Where les are located; how and when you save les
How the Math/Text toggle and other mathematics controls
operate
Which fonts are used to display characters not in the
standard ASCII range, and how the Input Method Editor
(IME) behaves when entering and leaving mathematics

3. Specify the setting you want by checking or unchecking boxes and buttons, entering
numbers to indicate settings, or typing information in the dialog boxes.
4. Choose OK.

3

Computing and Plotting

In SWP and SNB, you can perform basic and complex mathematical computations
right in your document. You can use the computational engine to perform symbolic
computations fundamental to algebra, trigonometry, and calculus: evaluating, factoring,
combining, expanding, and simplifying terms and expressions containing integers, fractions, and real and complex numbers. You can also perform integration, differentiation,
matrix and vector operations, standard deviations, and many other more complex computations involved in calculus, linear algebra, differential equations, and statistics. SW
and SV don't include a computational engine.
You can plot the results of your computations or use them to perform additional
computations. You can plot additional items by dragging them onto an existing plot. You
can build a series of expressions that show a step-by-step approach to a problem solution
by computing in place—performing computations within an expression, rather than on
an entire expression. And you can perform computations on data les you import from
your calculator. Finally, you can combine the power of the computational engine and the
Exam Builder to create algorithmically-generated, computer-graded course materials.
Use the Engine Setup tab sheet on the Tools menu to display a full or simpli ed
Compute menu. Extensive information about computing and plotting appears in the online Help and in Doing Mathematics with Scienti c WorkPlace and Scienti c Notebook.
To try the sample computations in this chapter, display the Math Templates, Math
Objects, Compute, and Symbol Cache toolbars. Results may differ slightly depending
on the defaults selected.
I To perform a computation or plot a graph
1. Enter a mathematical expression.
2. With the insertion point in or at the immediate right of the expression, choose the
command you want from the Compute menu or the Compute toolbar:
Evaluate

Solve
Exact

Plot 3D
Show
Expand Rectangular Definitions

Evaluate Simplify Plot 2D
New
Numerically
Rectangular Definition

While the computation takes place, the program displays a computational pointer.
Then, the program inserts the result in your document. Most computations are fast, but
some take several minutes. Occasionally, you may want to cancel a computation.
I To stop a computation
Click

or press CTRL + BREAK .
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Evaluate and Evaluate Numerically
You can easily collect terms, nd the sum or difference of polynomials, change a quotient to rational form, or raise a number to a power with the Evaluate and Evaluate
Numerically commands. When you evaluate an expression, the computational engine
returns an exact or symbolic answer whenever appropriate and a numerical approximation otherwise. You can use the Evaluate Numerically command to force a numerical
result for any evaluation.
p
Example Evaluate 2:36
1. Click

. The program starts mathematics automatically.
p
2. Type 2.36. Your screen shows the expression 2:36:
3. Click

. The computational engine evaluates and you see this result:
p

Example Evaluate (0:16)
1. Click

2:36.= 1: 536 2

1

. The program starts mathematics automatically.

2. Type 0.16, and press the spacebar.
3. Click

and type -1. Your screen shows the expression (0:16)

4. Click

. The computational engine evaluates the expression:
(0:16)

1

Example Evaluate Numerically 936
1. Click

:

= 6: 25

14

or, from the Insert menu, choose Math to start mathematics.

2. Type 936, click
3. Click

1

on the Symbol Cache toolbar, and type 14.

. Your screen displays this result:
936

14 = 66: 857

Evaluate and Evaluate Numerically
Example Evaluate
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Numerically

1. On the Symbol Cache toolbar, click
yields this result:

, and then click

. The evaluation

=: 3: 141 6
2. Now see how the results differ when you change the numerical accuracy with which
the computational engine operates:
a. From the Tools menu, choose Engine Setup and choose the General tab.
b. Change the setting for Digits Used in Computations to 20 and choose OK.
c. From the Tools menu, choose Computation Setup and choose the General tab.
d. Change the setting for Digits Shown in Results to 20 and choose OK.
e. Press ENTER , click

, and then click

. Now you see this result:

= 3: 141 592 653 589 793 238 5
3. Return to the original settings for Digits Used in Computations and Digits Shown
in Results.
Evaluate these expressions
Compute these expressions with Evaluate:
27 + 33

16

14:2

83:5

j 11:3j

3x2 + 3x + 8x2 + 7

Compute these expressions with Evaluate Numerically:
Z 1
p
2
8
2
ex dx
9
0

Compute these expressions with Evaluate and Evaluate Numerically; note the
different results:.
2
3
8
7

5
8

1
7

(x + 3) + (x

y)

4

3
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Factor
You can use the Factor command when you need to nd the elements or quantities
whose multiplication gives a certain product or polynomial.
Example Factor 12345
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type 12345.
3. From the Compute menu, choose Factor. Your screen shows this result:
12345 = 3

Example Factor x2
1. Click

5

823

y2

or, from the Insert menu, choose Math to start mathematics.

2. Type x, click
3. Type -y, click

, type 2, and press the spacebar.
, and type 2.

4. From the Compute menu, choose Factor. Your screen shows this result:
x2

y 2 = (x

y) (x + y)

x6

1 2
x + 3x
2
10x2 + 5x + 5

Factor these expressions
24!
5x5 + 5x4

y6

10x3

20
9

Combine
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Combine
In addition to combining the items in mathematical expressions, you can use the Combine command to demonstrate the laws of exponents and the properties of logarithms.
Example Combine sin x cos y + cos x sin y
You don't need to type any spaces as you enter the functions. The program interprets
the trigonometric functions and formats the expression correctly. Note that because
Automatic Substitution is on by default, the function names are displayed in gray.
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type sinxcosy+cosxsiny.
3. From the Compute menu, choose Combine, and then choose Trig Functions. This
is the result:
sin x cos y + cos x sin y = sin (x + y)
Example Combine the powers of 10x 10y
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type 10, click

, type x, and then press the spacebar.

3. Type 10, click

, and type y.

4. From the Compute menu, choose Combine, and then choose Powers. After the
calculation is complete, your screen shows this result:
10x 10y = 10x+y

Combine the terms in these expressions
y

(ex )

sin x sin y

y

(2x )
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Expand
You can expand the products or powers of polynomials with the Expand command.
Example Expand
1. Click

18229
94

.

2. Type 18229, press TAB , and type 94.
3. Click

to obtain this result:
18229
94

87
= 193 94

Example Expand sin 2x
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type sin.
The program automatically recognizes the trigonometric function and displays it on
your screen in gray.
3. Type 2x.
4. Click

. After the computation, you see this result:
sin 2x = 2 cos x sin x

Expand these expressions
3x2 + 3x

3

sin (x + y)

3x2 + 3x

8x2 + 7

4

(x + y)

Simplify
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Simplify
You can reduce expressions to standard form, collecting like terms in addition and canceling common factors in division. When possible, the computational engine performs
indicated operations exactly or reduces them to lower-level operations.
Example Simplify 4a + 7b

(2a + b)

or, from the Insert menu, choose Math to start mathematics.

1. Click

2. Type 4a+7b-, click
returns this answer:

, type 2a+b, and click

4a + 7b

Example Simplify x2

. The computational engine

(2a + b) = 2a + 6b

6x +

6 2
2

+ y 2 + 10y

10 2
2

1. Enter the rst expression:
a. Click

, type x, click

, type 2, and press the spacebar.

b. Type -6x+, click
, and then click
.
c. Type -6, press TAB , type 2, and press the spacebar twice.
d. Click

, type 2, and press the spacebar twice.

2. Type the second expression:
a. Type + , click

, type y, click

b. Type +10y, click

, type 2, and press the spacebar.

, and then click

.

c. Type 10, press TAB , type 2, press the spacebar twice, click
3. Click

, and type 2.

. The computational engine simpli es the mathematics:
x2

6x +

6 2
2

+ y 2 + 10y

10 2
2

= x2

6x + y 2 + 250y + 9

Simplify these expressions
p
3

8+3

sin2 x + cos2 x

Z

1

a

1
dt
t

14

5
9
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Check Equality
You can determine whether an equality is true or false or whether, if the test is inconclusive, the inequality may be true or false.
Example Check the equality 1 + 1 = 3
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type 1+1=3.
3. From the Compute menu, choose Check Equality. You see this result:
1 + 1 = 3 is false

Example Check the equality
1. Click

9
8

8
9

=

9
8

8
9

, type 9, press TAB , type 8, and press the spacebar.

2. Type - , click

, type 8, press TAB , type 9, and press the spacebar.

3. Type = , click

, select

, and choose OK.

4. Type the two fractions again.
5. From the Compute menu, choose Check Equality. This is the result:
9
8

8
9

=

9
8

8
9

is true

Check these equalities
ei =

1

= 3:14

sin2 x + cos2 x = 1

Solve Exact and Numeric

47

Solve Exact and Numeric
As with evaluation, when you solve an expression, the computational engine returns
an exact or symbolic answer whenever appropriate. You can use the Solve Numeric
command to force a numerical result for any solution.
You can solve equations with one or more variables. You can solve inequalities with
Solve Exact. And you can solve a system of equations if you place the equations in a
matrix cell and then apply the Solve Exact command to the matrix.
Example Solve Exact 3x + 5
1. Click

5x

3

or, from the Insert menu, choose Math to start mathematics.

2. Type 3x+5.
3. On the Symbol Cache toolbar, click

.

4. Type 5x-3.
5. Click
or, from the Compute menu, choose Solve, and then choose Exact.
On your screen, you see this solution:
3x + 5

5x

3, Solution is: [4; 1)

Example Solve Exact 2x + 3y = 1
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type 2x+3y=1. Remember that you don't need to enter any spaces; the program
spaces the expression correctly.
3. From the Compute menu, choose Solve, and then choose Exact.
4. In the Solution Variables box, enter x and choose OK. The computational engine
presents this solution:
2x + 3y = 1, Solution is:

1
2

3
2y
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Example Solve Numeric x2

2=0

or, from the Insert menu, choose Math to start mathematics.

1. Click

2. Type x, click

, type 2, and press the spacebar.

3. Type -2=0.
4. From the Compute menu, choose Solve, and then choose Numeric. The computational engine returns this numeric solution:
x2

2 = 0, Solution is: f[x =

1: 414 2] ; [x = 1: 414 2]g

Example Solve a system of equations
1. Click

or, from the Insert menu, choose Matrix.

2. Specify 2 rows and 1 column, and then choose OK.
3. Type 2x+3y=41 and press TAB .
4. Type x+y=146 and press the spacebar. You see this matrix:
2x + 3y = 41
x + y = 146
5. From the Compute menu, choose Solve, and then choose Exact. The computational engine solves the system of equations in the matrix and displays this result:
2x + 3y = 41
, Solution is: [x = 397; y =
x + y = 146

251]

Solve these expressions
Use Solve Exact to solve these relations:
1
1
+ = 1 (for x)
x2 5x + 4 = 0
x y

7 2x
x 2

0

2x + y = 5
3x 7y = 2

Use Solve Numeric to solve these relations:
16

7y = 10y

4

x5

5x4 + 3x + 4 = 0

sin x = cos x
x 2 (9; 12)

Work with Polynomials
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Work with Polynomials
Use the commands on the Polynomials and Calculus submenus to collect and order
the terms in polynomials, divide polynomials, nd roots, and write a rational expression
as the sum of partial fractions.
Example Collect the terms in 3x
1. Click

7x2 + 8x

3 + x5

or, from the Insert menu, choose Math to start mathematics.

2. Type 3x-7x, click

, type 2, and press the spacebar.

3. Type +8x-3+x, click

, type 5, and press the spacebar.

4. From the Compute menu, choose Polynomials, and then choose Collect.
5. Type x in the Need Polynomial Variable dialog box and choose OK. The computational engine collects the terms and displays this result:
7x2 + 8x

3x

3 + x5 = x5

Example Order the terms in 3xt2
1. Click

7x2 + 11x

16t5 + y + 9

3

2xt2

or, from the Insert menu, choose Math to start mathematics.

2. Type 3xt, click

, type 2, and press the spacebar.

3. Type -16t, click

, type 5, and press the spacebar.

4. Type +y +9-2xt, click

, type 2, and press the spacebar.

5. From the Compute menu, choose Polynomials, and then choose Sort.
6. Type t in the Need Polynomial Variable dialog box and choose OK. The computational engine orders the terms and then displays this result:
3xt2

16t5 + y + 9

2xt2 =

16t5 + t2 x + y + 9

Example Write this expression as the sum of partial fractions:
1. Click

.

2. Type x, click
3. Type -5x, click

, type 6, and press the spacebar.
, type 4, and press the spacebar.

x6 5x4 +3x+4
(x2 2)(x+3)3
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4. Type +3x+4 and press TAB .
5. Click

, type x, click

, type 2, and press the spacebar.

6. Type -2 and press the spacebar.
7. Click

, type x+3, and press the spacebar.

8. Click

and type 3.

9. From the Compute menu, choose Calculus, and then choose Partial Fractions.
The computational engine computes the partial fraction and returns this result:
x6 5x4 +3x+4
(x2 2)(x+3)3

=x+

367
343 x
x2

534
343

2

+

17 126
343(x+3)

4491
49(x+3)2

+

319
7(x+3)3

9

Example Find the roots of the expression x2 + 4
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type x, click

, type 2, press the spacebar, and type +4.

3. From the Compute menu, choose Polynomials, and then choose Roots. Your
screen shows this result:
x2 + 4, roots:

2i
2i

Try these exercises with polynomials
Collect the terms in these expressions:
5t2 + 2t 16t5 + t3 2t2 + 9
x2 + y + 5 3x3 y + 5x2 + 4y 3 + 13 + 2x4 (Use the variable x)
Order the terms in these expressions:
3x 7x2 + 8x 3 + x5
2
3
x + y + 5 3x y + 5x2 + 4y 3 + 13 + 2x4 (Use the variable x)
Divide these polynomials:
x5 5x4 + 3x + 4
x2 2

3x2 + 3x
(8x2 + 7)

Find the roots of these expressions:
x3

2x

2x2 + 4

x3

13 2
ix
5

8x2 +

29
81
ix + x + 6i
5
5

18
5
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Create 2D and 3D Plots
In SWP and SNB, you can create 2-dimensional and 3-dimensional plots of polynomials, trigonometric functions, and exponentials.
Example Plot x2
1. Click
type 2.

or, from the Insert menu, choose Math, then type x, click

, and

2. Click
or, from the Compute menu, choose Plot 2D and then choose Rectangular. The computational engine plots the expression x2 :
y 24
22
20
18
16
14
12
10
8
6
4
2
-5

-4

-3

-2

-1

0

1

2

3

4

5
x

3. Add to the plot:
a. Press ENTER to start a new line and then start mathematics.
b. Type x, click
, and type 3.
c. Select the expression x3 and drag it onto the plot. The computational engine replots, adding the new function:
y 120
100
80
60
40
20
-5

-4

-3

-2

-1

-20
-40
-60
-80
-100
-120

1

2

3

4

5
x
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Example Create a polar plot
1. Click

or, from the Insert menu, choose Math, then type sin2t.

2. From the Compute menu, choose Plot 2D and then choose Polar. The computational engine plots the expression sin 2t:
y
0.6
0.4
0.2

-0.7 -0.6 -0.5 -0.4 -0.3 -0.2 -0.1

0.1 0.2 0.3 0.4 0.5 0.6 0.7
x

-0.2
-0.4
-0.6

Example Plot ln x
1. Click

or, from the Insert menu, choose Math, then type lnx.

2. Click
or, from the Compute menu, choose Plot 2D and then choose Rectangular. The computational engine plots the expression:
y 1.6
1.4
1.2
1.0
0.8
0.6
0.4
0.2
0.0
-0.2
-0.4
-0.6
-0.8

1

2

3

4

5
x
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Example Plot x2 y 3
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type x, click
type 3.

, type 2, and press the spacebar; then type y, click

, and

3. Click
or, from the Compute menu, choose Plot 3D and then choose Rectangular. The computational engine plots the expression x2 y 3 :

4. If you want this plot to appear more clearly in print, you can change its properties:
a. Select the plot and click the Graphic Properties icon
of the plot.
b. Choose the Items Plotted tab.
c. In the Directional Shading area, choose Flat.
d. In the Base Color area, choose Black.
e. In the Surface Style area, choose Wire Frame.
f. Select the Axes tab.
g. In the Axes Type area, choose None.
h. Select the View tab.
i. In the Orientation area, set Turn to 34.
j. Choose OK.
Here's the result:

in the lower right corner
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Example Plot [x sin x cos y; x cos x cos y; x sin y]
1. Click

.

2. Type xsinxcosy,xcosxcosy,xsiny.
3. Click
or, from the Compute menu, choose Plot 3D and then choose Rectangular. The computational engine produces a plot whose components you can
change:

4. Change the plot properties:
a. Select the plot and click the Graphic Properties icon
in the lower right corner
of the plot.
b. Choose the Items Plotted tab.
c. In the Directional Shading area, choose Flat.
d. In the Base Color area, choose Black.
e. In the Surface Style area, select Wire Frame.
f. Choose Variables and Intervals.
g. In the Plot Intervals area, set the interval values for x to 0 to 6.28.
h. Set the interval values for y to 0 to 3.14 and choose OK.
i. Select the Axes tab.
j. In the Axes Type area, choose None and choose OK.
The computational engine replots the expression [x sin x cos y; x cos x cos y; x sin y]:

Compute in Place
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Plot these expressions
Use Plot 2D, Rectangular to plot x sin

1
x

Use Plot 2D, Parametric to plot (sin 2t; cos 3t)
2

Use Plot 2D, Implicit to plot (x
and

2

y

2

3) = 25, where

2) + (y

3

x

7

8; edit the plot to choose Equal Scaling from the Axes tab

Use Plot 3D, Cylindrical to plot 1

z, where 0

Use Plot 3D, Spherical to plot 2, where 0

2 and 0
2 and 0

z

z

1

2

Compute in Place
You can use many computational commands to compute in place, replacing part of an
expression with the result of an operation. You can use this technique to demonstrate
the steps involved in the solution to a problem.
Example Simplify
1. Click

x2 5x+6
x2 2x 3

, type x, click

and show the steps in the solution
, type 2, press the spacebar, and type -5x+6.

2. Press TAB, type x, click

, type 2, press the spacebar, and type -2x-3.

3. Position the insertion point after the original expression and type =.
4. Select the original expression.
5. Hold down the CTRL key while you drag a copy of the expression to the right of the
rst equals sign.
6. Select the numerator in the copied expression, then hold down the
you choose Factor from the Compute menu.

CTRL

key while

7. Select the denominator in the copied expression, then hold down the CTRL key while
you choose Factor from the Compute menu.
8. Click
. The computational engine returns this result. Now, you see all the steps
in the solution:
x2 5x+6
x2 2x 3

=

(x 2)(x 3)
(x+1)(x 3)

=

1
x+1

(x

2)

Compute in place to show the steps in the solutions of this problem
Simplify

x2 4x 21
x3 +3x2 x 3

to

1
(x 1)(x+1)

(x

7), showing the steps in the process
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Perform Matrix Operations
You can perform a full range of matrix operations including addition, multiplication,
and inversion.
2
3
1 4
Example Transpose the matrix 42 55
3 6
1. Click
and specify a matrix of 3 rows and 2 columns.
2. In the Built-in Delimiters area, specify Brackets [m] and choose OK.
3. Fill the matrix:
a. Type 1, press TAB , type 4, and press TAB .
b. Type 2, press TAB , type 5, and press TAB .
c. Type 3, press TAB , type 6.
4. From the Compute menu, choose Matrices and then choose Transpose. The computational engine transposes the matrix:
2
1
42
3

3
4
1
55, transpose:
4
6

Example Invert the matrix
1. Click

1
7

2
5

3
6

2
3

and specify a matrix of 2 rows and 2 columns.

2. In the Built-in Delimiters area, specify Brackets [m] and choose OK.
3. Fill the matrix: type 1, press TAB , type 2, press TAB , type 7, press TAB , and type -3.
4. From the Compute menu, choose Matrices and then choose Inverse. The computational engine inverts the matrix:

1
7

2
, inverse:
3

2

3
4 17
7
17

3

2
17 5
1
17

Perform these matrix operations
Adjugate

97
56

50
49

Find the determinant of

Concatenate
a b
c d

a 5
6 b

9
d

c
4
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Solve Differential Equations
Many differential equations have answers in terms of familiar functions. You can use
the Solve ODE command to nd those functions. If you specify initial conditions for
an equation, you can solve the equation numerically.
Example Compute
1. Click

dy
dx

=x

.

2. Type dy, press TAB , type dx, and press the spacebar.
3. Type =x.
4. From the Compute menu, choose Solve ODE, and then choose Exact. The computational engine gives this result:
dy
dx

= x, Exact solution is:

1 2
2x

+ C2

Example Find the solution of the initial value problem
1. Click

y0 = y
y (0) = 1

and specify a matrix of 2 rows and 1 column.

2. In the Built-in Delimiters area, specify Brackets [m] and then choose OK.
3. Type y'=y and press TAB .
4. Type y, click

, type 0, and press the spacebar.

5. Type =1 and press the spacebar.
6. From the Compute menu, choose Solve ODE, and then choose Exact.
7. Type x as the independent variable you want the computational engine to use and
choose OK. The computational engine returns this result:
y0 = y
, Exact solution is: fex g
y (0) = 1
Compute these differential equations
dx
= 2xy
dy

y 00 = y

y 00 + y = 0
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Compute Statistics
Basic and advanced statistical computations are available.
Example Find the modes of 1; 1; 3; 4; 4; 4; 5; 3; 8; 1; 9; 5; 2
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type the numbers 1,1,3,4,4,4,5,3,8,1,9,5,2. Include the commas.
3. From the Compute menu, choose Statistics, and then choose Mode. The computational engine returns this answer (the modes are the numbers in brackets and the
nal number indicates the number of times that each mode appears in the set):
Mode(s): [1; 4] ; 3
2
1:5
Example Find the medians of the columns of the matrix 43:9
5:5
1. Click
, and specify a matrix of 3 rows and 2 columns.

3
6:7
2:25
4:3

2. In the Built-in Delimiters area, specify Brackets [m] and then choose OK.
3. Fill the matrix with the values 1.5, 6.7, 3.9, 2.2, 5.5, and 4.3, pressing TAB to move
from cell to cell.
4. From the Compute menu, choose Statistics, and then choose Median. The computational engine returns these medians:
Median(s): [3: 9; 4: 3]
Example Find the standard deviation of 2:5; 6:8; 3:5; 1:9; 2:3; 4:5
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Enter the numbers 2.5, 6.8, 3.5, 1.9, 2.3, and 4.5, separated by commas.
3. From the Compute menu, choose Statistics, and then choose Standard Deviation.
The computational engine returns this answer:
Standard deviation(s): 1: 835 7
Compute these statistics
Find the mean of these values:

1; 2; 3; 4

1:5
3:9

6:7
2:2

Find the variance of 2:5; 6:8; 3:5; 1:9; 2:3; 4:5
Using multiple regression, t a curve to these points (dependent
variable in column 2):

2

x
6 1
6
4 2
3

3
y
2 7
7
4 5
7
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Compute with Units of Measure
You can convert values from one unit of physical measure to another and perform computations on equations containing units.
Example Convert 28:6 pound-force to newtons
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type 28.6 and then click

or, from the Insert menu, choose Unit Name.

3. In the Physical Quantity box, select Force.
4. In the Unit Name area, select Pound-force, and then choose Insert. The program
inserts the unit of measure and leaves the Unit Name dialog box open.
5. Type =x.
6. In the Unit Name area, select Newton, choose Insert, and close the dialog box.
7. Click

or, from the Compute menu, choose Solve, and then choose Exact.

The computational engine yields this result:
28:6 lbf = x N, Solution is: f127: 22g
Example Express 20:0 miles/hour in kilometers/minute
1. Click

or, from the Insert menu, choose Math to start mathematics.

2. Type 20.0 and then click

or, from the Insert menu, choose Unit Name.

3. In the Physical Quantity box, select Length.
4. In the Unit Name area, select Mile and choose Insert.
5. Type /.
6. In the Physical Quantity area, select Time.
7. In the Unit Name area, select Hour, and choose Insert.
8. Type =x.
9. In the Physical Quantity area, select Length.
10. In the Unit Name area, select Kilometer, and choose Insert.
11. Type /.
12. In the Physical Quantity area, select Time.
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13. In the Unit Name area, select Minute, and choose Insert and close the dialog box.
14. Click
or, from the Compute menu, choose Solve and then choose Exact.
This is the result:
20:0 mi= h = x km= min, Solution is: 0:536 45

Compute these conversions
Express 53:7 lbf= in2 in newtons per square meter
Compute 3 A6 V and then convert the answer to watts
Convert 3:7 N= cm2 to pounds per square inch

Create Exams and Quizzes
In SWP and SNB, you can create algorithmically-generated course materials such as
exams, quizzes, tests, tutorials, problem sets, drills, and homework assignments. Instead
of writing a series of exams, each containing a variation of your questions and answers,
you can use the Exam Builder to write a single exam and state the questions and answers
with algorithms. Students can drill and practice a skill at length by opening the same
Exam Builder le repeatedly, obtaining a different set of questions each time. Similarly,
you can test each student with a different version of an exam, with each version drawn
from the same Exam Builder source le.
The Exam Builder is appropriate for any level of mathematics instruction—elementary arithmetic, algebra, trigonometry, calculus, linear algebra, differential equations,
probability, or statistics. Course materials created with the Exam Builder can be worked
and graded online or in the traditional pencil-and-paper form. The online Help system
contains detailed instructions for using the Exam Builder.
You can nd many sample quizzes in the Quizzes directory of your program installation. These instructions explain how to open and take one of the sample exams.
I To open a quiz
1. Open SWP or SNB and from the File menu, choose Open.
2. Specify the Quizzes directory of your program installation.
3. In the Files of type box, choose Quiz (*.qiz).
4. Select one of the les in the directory and choose OK to open the sample exam.
5. Enter your name on the exam and answer each question.
6. Choose Click to grade. The program grades the exam and opens a le containing
the results.
7. Open the same .qiz le again and note that the program has automatically generated
a different set of questions.

4

Typesetting Your Document

With MacKichan Software products, you can create beautiful documents for use online or in print. If you have SWP or SW, you can typeset your documents with
LATEX, which creates nely formatted documents with automatically generated tables
of contents, cross-references, citations, and other document elements. With Version 5 of
SWP and SW, you can also create typeset Portable Document Format (PDF) les with
PDF TEX, which processes documents through PDF LATEX to provide all the beauty and
features of LATEX typesetting in PDF form. If you have SNB or you're using SWP or
SW to produce documents that don't require typesetting, you can print attractive documents without LATEX.
SWP and SW are supplied with TrueTEX, which includes a TEX formatter, a TEX
screen previewer, and scalable TrueType fonts. The version of TrueTEX shipped with
SWP and SW also includes PDFTEX support. No other software is required to generate
PDF les, but you must have a PDF viewer to be able to preview and print PDF les.
More information about using other previewers and print drivers is available in the online
Help and in Creating Documents with Scienti c WorkPlace and Scienti c Word.
We refer to the processes that involve LATEX typesetting as typeset compile, typeset preview, and typeset print, and to those that involve PDFTEX typesetting as typeset
compile PDF, typeset preview PDF, and typeset print PDF. (The processes are similar;
general statements about typesetting refer to both sets of processes.) We refer to the
processes that don't involve any typesetting as simply preview and print.
You typeset your document using commands on the Typeset menu or the buttons on
the Typeset toolbar (available in SWP and SW only):
Menu

Command

Compile

Typeset

Compile PDF

Typeset

Preview

Typeset

Preview PDF

Typeset

Print

Typeset

Print PDF

Menu

Command

Typeset

Button

Button

You produce your document without typesetting using the commands on the File menu
or buttons on the Standard toolbar:
Menu Command Button
File

Preview

File

Print

Each time you preview or print your SWP or SW document, you can choose whether
or not to typeset it. The results differ noticeably.
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Understanding the Typesetting Process
When you typeset, the program compiles your document with LATEX or PDFLATEX. The
compilation applies special LATEX formatting features to resolve typographic details such
as hyphenation, ligatures, line spacing, and line and page breaking. The process also
creates automatic numbering, cross-references, citations, and footnotes. It generates
any document elements speci ed in the document shell, such as a table of contents,
bibliography, or index. Depending on the complexity of your document, the program
may process it through LATEX or PDFLATEX more than once. During the compilation,
SWP and SW remain open, but they are suspended.
The results of the compilation differ depending on whether you typeset your document with LATEX or PDFLATEX. In either case, your original document is unchanged.
If you typeset with LATEX (using the Preview or Print commands on the Typeset
menu), the compilation yields a device independent, or DVI, le that contains your
typeset document in a form independent of any output device. The compilation may
also result in other generated les, such as table of contents les or bibliography
les, that are required by the DVI le.
If you typeset with PDFLATEX (using the Preview PDF or Print PDF commands
on the Typeset menu), the compilation yields a PDF le that contains your typeset
document embedded with all necessary fonts and graphics. If you have added the
hyperref package to your document, the compilation creates hypertext links in place
of cross-references and links the table of contents to the rest of the document with
hypertext links.
If you typeset with the Compile or Compile PDF command, the program compiles
the document and creates the DVI or PDF le but doesn't preview or print it. Otherwise,
following the compilation, the program previews or prints the le, according to your
choice. Because of the typesetting speci cations and the features and elements added
during compilation, the appearance of your document may be quite different from its
appearance in the document window.
When you don't typeset your document, the program uses many of the same routines to preview and print as it does to display the document on the screen. The program
doesn't use special formatting features, nor does it automatically generate any document elements. Therefore, the appearance of the previewed or printed document is quite
similar to its appearance in the document window.
These general guidelines may help you decide which document production method
to use:
When a nely typeset document appearance is a high priority, typeset preview or
typeset print the document with the commands on the Typeset menu.
When you need a nely typeset PDF document for viewing on multiple platforms,
typeset the document with the PDF commands on the Typeset menu.
When a nely typeset document appearance and automatically generated document
elements aren't a priority or you need output quickly, preview or print the document
with the commands on the File menu.

Typeset Previewing and Typeset Printing
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Typeset Previewing and Typeset Printing
You can examine the typeset appearance of your document before you print it. You can
send it to the printer from the document window, the TrueTEX preview window, or the
window of your PDF viewer. You can also access the TrueTEX Formatter and Previewer
from the program submenu on the Windows Programs menu. PDFLATEX isn't available
outside SWP or SW.
I To typeset preview a document
1. From the Typeset menu, choose Output Choice.
2. Select the type of output you want, and choose OK.
3. On the Typeset toolbar, click the Typeset DVI Preview button
Typeset menu, choose Preview.

or, from the

or
On the Typeset toolbar, click the Typeset PDF Preview button
Typeset menu, choose Preview PDF.

or, from the

If your document doesn't have a current DVI or PDF le, the program automatically
compiles the document, then opens the TrueTEX preview screen or your PDF viewer
to display your document as it will appear in print.
4. Use the scroll bars, keyboard, or menu commands to examine your document.
5. Choose Exit from the File menu to leave the previewer.
I To typeset print a document from the document window
1. From the Typeset menu, choose Output Choice.
2. Select the type of output you want, and choose OK.
3. On the Typeset toolbar, click the Typeset DVI Print button
menu, choose Print; or press CTRL + P.

; from the Typeset

or
On the Typeset toolbar, click the Typeset PDF Print button
set menu, choose Print PDF.

or, from the Type-

The program compiles the document if necessary.
4. Make any necessary selections in the Print dialog box, and then choose OK.
I To typeset print a document from the TrueTEX Previewer or PDF viewer
1. From the Typeset menu, choose Output Choice.
2. Select the type of output you want, and choose OK.
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3. From the Typeset menu, choose Preview or Preview PDF.
The program compiles the document if necessary.
4. From the File menu in the TrueTEX preview window or the PDF viewer, choose
Print.
5. Select the printer and print speci cations you want, and then choose Print.
Remember that you can use the Compile and Compile PDF commands on the
Typeset menu to compile your document independently and then preview or print the
typeset document at a different time. The Compile commands are active only when
you've saved the document and made no further changes.
I To compile a document
1. From the Typeset menu, choose Output Choice.
2. Select the type of output you want, and choose OK.
3. Save the document.
4. On the Typeset toolbar, click the Typeset DVI Compile button
Typeset menu, choose Compile.

or, from the

or
On the Typeset toolbar, click the Typeset PDF Compile button
Typeset menu, choose Compile PDF.

or, from the

5. Select the options you want from the Compile or Compile PDF dialog box, and
then choose OK.

Understanding the Appearance of Typeset Documents
When you typeset, the program formats your document using these speci cations:
The typesetting speci cations for the document shell. The speci cations are a collection of LATEX formatting instructions that govern all aspects of the typeset appearance
of your document: type face, type size, margins, page size, line spacing, location and
appearance of headers and footers, paragraph layout and indention, section headings, page breaks, and countless other typographic details. The speci cations are
contained in les with extensions of .sty and .cls.
Any speci ed LATEX class options or LATEX packages speci ed for the document or
its shell. Class options and packages contain instructions that modify the typesetting speci cations in some way. Class options are contained in les with a .clo
extension; LATEX package les have an .sty extension.
Any additional TEX or LATEX commands you have entered in the document itself.
The typesetting speci cations are set initially by the shell you use to create your
document. Some modi cations to the shell and the document are possible by modifying

Creating Typeset Document Elements
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LATEX class options, adding packages, and using commands on the Typeset menu, as
described in Typesetting Documents in Scienti c WorkPlace and Scienti c Word. We
discourage attempts to modify the speci cations if you aren't extremely familiar with
TEX and LATEX. If the shell for your document doesn't produce the typeset results you
want, start a new document with a shell that meets your requirements more closely.
Note Don't attempt to modify the typesetting speci cations unless you are familiar
with TEX and LATEX.
The program uses the typesetting speci cations only when you typeset. When you
produce the document without typesetting it, the program ignores the typesetting speci cations. Instead, it uses the margins, headers, footers, and page numbers speci ed
in the Page Setup dialog box and the tag properties speci ed in the style (.cst le).
Modi cations to tag properties that you make from the Tag Appearance dialog box do
not affect the typeset appearance of your document.
In other words, the way you choose to produce your document determines which set
of speci cations the program uses and, consequently, how your document appears on
the preview screen and in print.
When the document is
Produced with LATEX or
PDF LATEX typesetting

The program formats according to
Typesetting speci cations,
LATEX options and packages,
LATEX commands

Displayed in the document window
Produced without typesetting

Style, View settings
Style, Page setup speci cations,
Print options

Creating Typeset Document Elements
Many document shells contain prede ned elds that instruct LATEX and PDFTEX to generate document elements—especially those in the front matter, such as title pages and
abstracts—when you typeset your document. If you don't typeset, the elds are ignored
and the elements aren't generated.
As you build your document, you can add objects that automatically create other
document elements (such as notes, citations, index entries, and cross-references to numbered parts of the document) whenever you typeset.
If you add the hyperref package to your SWP or SW document and then typeset
with PDF, the program not only creates any cross-references, page references, notes,
and citations, but also converts them to hypertext links. Then, the resulting PDF le
contains live hypertext links that you can use to jump from one part of the PDF le
to another when you view the le with a PDF viewer. See Typesetting Documents in
Scienti c WorkPlace and Scienti c Word and the online Help for more information about
the hyperref package.
Also, if you are very familiar with TEX and know the TEX or LATEX command for an
object or operation not available in the program, you can enter it in your document in a
TEX eld.
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Important Remember that you must typeset your document to generate document
elements. If you produce your document without typesetting it, the program doesn't
process the document with LATEX and the elements aren't generated, so the eld or object
doesn't appear in print.

Creating Cross-References
When you typeset your document, you can generate automatic cross-references to other
numbered objects in your document, such as equations, theorems, graphics, or sections,
or to the pages on which they appear. Cross-references have two parts, a marker containing a key for the numbered object and the reference itself. When you typeset the
document, the cross-reference is resolved and replaced with the number of the marked
object. The hyperref package extends cross-reference capabilities; see Creating Documents with Scienti c WorkPlace and Scienti c Word for more information. If you don't
typeset, cross-references and markers don't appear in print.
I To create a marker for a numbered object
1. Place the insertion point where you want the marker.
2. On the Field toolbar, click the Marker button
Marker.

or, from the Insert menu, choose

3. In the Key box, enter a unique key for the object, and then choose OK.
When the Markers display is turned on in the View menu, a marker looks like this
in the document window:

.

4. Save the document.
Note that creating markers for graphics, numbered equations, and manual bibliography items requires a different process; see online Help for more information.
I To create a cross-reference to a numbered object
1. Place the insertion point where you want the reference to appear.
2. On the Typeset Object toolbar, click the Cross Reference button
or, from the
Insert menu, choose Typeset Object, and then choose Cross Reference.
3. In the Print area, choose Object Counter.
4. In the Key area, enter the key of the marked object or click the arrow to the right to
select from a list of keys in the current document.
5. Choose OK.
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The program displays the reference on the screen in a gray box containing the word
.

ref and the key you entered, as in this example:

Creating Notes
Your documents can contain references to margin notes and footnotes that appear elsewhere in your document. When you typeset, a cross-reference to the note is generated
and the note is formatted according to the typesetting speci cations. If you don't typeset,
footnotes and margin notes don't appear in print.
I To enter a footnote
1. Place the insertion point where you want the reference to the footnote to appear.
2. On the Field toolbar, click the Note button
Note.

or, from the Insert menu, choose

3. In the Type of Note box, select footnote as the type of note.
4. Enter the text of the footnote, and then choose OK.
A footnote looks like this in the document window:

.

Creating Bibliographies and Citations
If the document shell supports bibliographies, you can create a bibliography list and
automatic cross-references, or citations, to items in the list. When you typeset your
document, the citation is generated and formatted correctly, according to the typesetting
speci cations for the shell.
You can create bibliographies in two ways. If your bibliography is complex, you
can create an automatic bibliography using BIBTEX, a public domain program created
by Oren Patashnik. BIBTEX generates and formats the bibliography list automatically by
extracting references from a database using the citations you insert into your document.
Because you don't have to create the bibliography list yourself, a BIBTEX bibliography
is convenient if you have a long list of references that you plan to use in other articles
or books. The creation and use of BIBTEX bibliographies is somewhat complex. Please
refer to the online Help for detailed instructions.
If your bibliography is a simple one, you can create it manually. A manual bibliography, which works just like a series of cross-references, is convenient when your list of
references is short and you don't plan to use those references in other articles or books.
You must format entries in a manual bibliography yourself.
I To specify a manual bibliography
1. From the Typeset menu, choose Bibliography Choice.
2. Select Manual Entry and choose OK.
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I To create a list of bibliography items
1. Move the insertion point to the end of the line that is to precede the bibliography,
and press ENTER .
2. Apply the Bibliography Item tag.
3. In the Bibliography Item Properties dialog box, enter a unique key for the item and
choose OK.
4. Type the bibliographic information for the item.
5. If you want to create another bibliographic item, press ENTER and repeat steps 3–4.
6. When you have completed all the entries, press ENTER and then click
the list.

to leave

I To create a citation for an item in a manual bibliography
1. Place the insertion point where you want the citation to appear.
2. On the Typeset Object toolbar, click the Citation button
menu, choose Typeset Object, and then choose Citation.

or, from the Insert

3. In the Citation dialog box, enter the key for the bibliography item you want to cite,
and then choose OK.
In the document window, you see the citation in a small gray box containing the key
for the bibliography item, like this:
. When you typeset the document, the
number of the item in the bibliography list replaces the key.

Obtaining More Information About Typesetting
A detailed discussion of LATEX typesetting is beyond the scope of this booklet. However, you can nd much more information about typesetting with SWP and SW in the
following sources:
The online Help.
Creating Documents with Scienti c WorkPlace and Scienti c Word.
Typesetting Documents in Scienti c WorkPlace and Scienti c Word.
You can nd more information about LATEX in these books:
LATEX, A Document Preparation System by Leslie Lamport.
The LATEX Companion by Michel Goossens, Frank Mittelbach, and Alexander Samarin.
A Guide to LATEX: Document Preparation for Beginners and Advanced Users by
Helmut Kopka and Patrick W. Daly.
Also, you can nd information about TEX in The TEXbook by Donald E. Knuth.
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Getting the Most from Your
Software

SWP, SW, and SNB are straightforward and easy to use, especially if you take advantage of the many resources available to you. The program is supplied with documentation including a Help system and tutorial materials that can help you learn how
to create documents and enter mathematics. If you have an Internet connection, additional documentation—in particular, the Help system for SV —is available from the
MacKichan Software website. Additionally, three manuals provide program details:
Creating Documents with Scienti c WorkPlace and Scienti c Word provides information about entering and editing text and mathematics; formatting documents;
structuring documents for typesetting and for use online; maintaining les; and customizing your installation. Much of the information in the manual is applicable to
SNB.
Doing Mathematics with Scienti c WorkPlace and Scienti c Notebook explains how
to use the built-in computer algebra system to do mathematics without dealing directly with the syntax of the computer algebra system. Along with examples and
exercises, the manual provides basic procedures for using the system to compute
and plot and to solve problems in analytic geometry, calculus, linear algebra, vector
analysis, differential equations, statistics, and applied modern algebra.
Typesetting Documents in Scienti c WorkPlace and Scienti c Word provides answers
to common questions about LATEX typesetting in SWP and SW. It helps you choose
document shells appropriately and explains when and how to tailor document shells
from within the program so that the documents you create meet your typesetting
needs more precisely.
Accompanying this version of the program is another volume, A Gallery of Document Shells for Scienti c WorkPlace and Scienti c Word, available on your program CD.
A Gallery of Document Shells explains the key characteristics of the shells provided with
the program. It contains brief discussions and illustrations of typeset documents created
with each shell (except those created with SNB, which are not intended for typesetting).
If you can't nd the information you need in one of these resources, technical support
is available. We regularly make additional information available on our unmoderated
discussion forum and email list. We also have an electronic newsletter that you can
request on our website or when you register your program.
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Using Online Help
The program includes an extensive Help system available online or from your CD-ROM.
While you're working, you can get information quickly from the online Help feature.
You can search Help to nd basic and advanced information about commands and operations, including instructions for using the built-in computational engine to perform numeric, symbolic, and graphic computations. If you save copies of the Help documents in
SWP or SNB, you can interact with the mathematics they contain, experimenting with
or reworking the included examples. In addition, two programs—the Style Editor and
the Document Manager—have their own online Help.
I To use the Help system
From the Help menu, choose the command you need:
Choose

To

Contents
Search...
Index

See a list of online information
Find a Help topic
Access the online index to General Information,
Computing Techniques, or the Reference Library
Open the link to the MacKichan Software, Inc.
website
Register your software and obtain a license
See a list of available features; change the serial
number for your installation
Obtain information about registering your system
Obtain information about your installation

MacKichan Software
Website
Register...
System Features...
License Information
About...

Also, we urge you to explore the supplemental technical documents supplied with
the program. You can open, view, and print the documents. In particular, we suggest
you read the following documents:
The document 50techref.tex in the Helpngeneral directory, which contains
technical information on the features in Version 5.
The documents in the Play directory, which demonstrate the use of computation in
SWP and SNB.
The documents in the SNSamples directory, which are examples of online documents created with the program.
The documents in the SWSamples directory, which include examples of documents
intended for typesetting in SWP and SW.
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Obtaining Technical Support
If you can't nd the answer to your questions in the manuals or the online Help, you can
obtain technical support from our website at
http://www.mackichan.com/techtalk/knowledgebase.html
or from our Web-based Technical Support forum at
http://www.mackichan.com/techtalk/UserForums.htm
You can also contact our Technical Support staff by email, telephone, or fax. We urge
you to submit questions by email whenever possible in case our technical staff needs to
obtain your le to diagnose and solve the problem.
When you contact us by email or fax, please provide complete information about
the problem you're trying to solve. We must be able to reproduce the problem exactly
from your instructions. When you contact us by telephone, you should be sitting at your
computer with the program running.
Please provide the following information any time you contact Technical Support:
The MacKichan Software product you have installed.
The version and build numbers of your installation (see Help / About).
The serial number of your installation (see Help / System Features).
The version of the Windows system you're using.
The type of hardware you're using, including network hardware.
A description of what happened and what you were doing when the problem occurred.
The exact wording of any messages that appeared on your computer screen.
I To contact technical support
Contact Technical Support by email, fax, or telephone between 8
ci c Time:

AM

and 5

PM

Pa-

Internet email address: support@mackichan.com
Fax: 360-394-6039
Telephone: 360-394-6033
Toll-free telephone: 877-SCI-WORD (877-724-9673) or
877-SCI-NOTE (877-724-6683)

Obtaining Additional Information
You can learn more about the program on our website, which we update regularly to
provide the latest technical information about the software. The site also houses links to
other TEX and LATEX resources. We maintain an unmoderated discussion forum and an
unmoderated email list so our users can share information, discuss common problems,
and contribute technical tips and solutions. You can link to these valuable resources
from our home page at
http://www.mackichan.com
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Chapter 5 Getting the Most from Your Software

Learning to Use the Program
You can learn a great deal about the program just by working with it. Start by opening
the program, typing a few sentences, entering some mathematics, and then previewing
and printing your document, as described in Chapter 1 “Tools for Scienti c Creativity.”
We also urge you to work through the tutorial exercises, available from online Help.
The exercises guide you step-by-step as you create several increasingly complex documents and learn how to enter a variety of mathematical expressions, compute while
working in your document, and print with and without typesetting.
I To open the tutorial exercises
1. From the Help menu, choose Contents.
2. Choose Learn the Basics.
3. Choose the exercise you want:
“Before You Start” provides information about the notation, terminology, and
instructions used in the exercises.
“Creating a Simple Document” provides instructions for creating a basic document.
“Printing and Typesetting” explains several ways to produce your document.
“Creating an Advanced Document” gives instructions for creating a somewhat
more complex document in SWP or SW. The exercise, which takes about 90
minutes to complete, focuses on document structuring, guiding you step-by-step
through the unique procedures for creating titles, headings, and theorem statements. Because the document you create contains equations, the exercise also
illustrates the straightforward entry and editing of mathematics.
“Creating Mathematics” presents a series of mathematical examples. The exercises give step-by-step instructions for entering a variety of mathematical expressions using the mouse and the keyboard.
“Sharing Your Work” presents information about creating documents for use
across platforms, installations, and systems; on a network; or on the Web.
“Performing Computations” presents a series of mathematical computation exercises. The step-by-step instructions guide you through basic computational
procedures for SWP and SNB.
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Compute Toolbar
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Solve
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Editing Toolbar
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Appendix A Toolbars and Buttons

Fragments Toolbar

Save Fragment

Fragments (Alt + 4)

History Toolbar
History
Back

Goto
Marker

History Forward

Link Toolbar
Table of
Contents

Beginning
Next
History
Document Document Back

Parent
Document

Previous
Document

End
Document

History
Forward

Math Toolbars
Fraction Superscript Parentheses Sum

Radical

Subscript

Square
Brackets

Unit
Name

Integral

Math Templates

Big
Operators Matrix Binomial Decoration

Display

Brackets

Math
Name

Label

Math Objects

Navigate Toolbar
Previous Section

Next Section

Section Heading (Alt + 5)

Goto Marker

Toolbars and Buttons

Standard Toolbar

New

Save

Open

Print

Open
Location

Spelling

Preview

Copy

Cut

Undo

Paste

Show/Hide
Nonprinting Table

Properties

Toggle
Text/Math

Zoom Factor

Stop Toolbar

Stop Operation

Symbol Cache Toolbar
Default con guration:

Symbol Panels Toolbar
Lowercase Binary
Negated Miscellaneous
General
Greek Operations Relations Symbols Latin-1 Punctuation

Uppercase Binary Arrows Special
Latin
Greek Relations
Delimiters Extended-A

Tag Toolbar

Remove
Item Tag

Item Tag (Alt + 1)

Section/Body Tag (Alt + 2)

Text Tag (Alt + 3)
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Appendix A Toolbars and Buttons

Typeset Object Toolbar
Cross
Citation Reference Subdocument

Index Entry

TeX
Field

Bibliography

Typeset Toolbar
Typeset
DVI
Print

Typeset
DVI
Compile

Typeset
DVI
Preview

Typeset
PDF
Preview

Typeset
PDF
Print

Front
Matter

Typeset
PDF
Compile

Options
and
Packages

B

Keyboard Shortcuts

These instructions assume that you haven't changed the program defaults.

Scrolling and Editing
Working with Files
To
Open a le
Close a le
Print
Exit
Open Help contents
Scrolling
To move
To the left
To the right
Up
Down
To start of the line
To end of the line
To next screen
To previous screen
To document start
To document end
To next eld inside a template
To previous eld inside a template
To outside a template
To the word to the right of the insertion
point
To the word to the left of the insertion
point
Between open documents

Press
CTRL + O
CTRL +F4
CTRL + P
ALT +F4

F1

Press
LEFT ARROW
RIGHT ARROW
UP ARROW
DOWN ARROW
HOME
END
PAGE DOWN
PAGE UP
CTRL + HOME
CTRL + END

or ARROW KEYS
SHIFT + TAB or ARROW KEYS
SPACEBAR or RIGHT ARROW or
LEFT ARROW (repeated)
CTRL + RIGHT ARROW
TAB

CTRL + LEFT ARROW
CTRL + TAB
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Appendix B Keyboard Shortcuts
Editing
To
Copy the selection to clipboard
Cut the selection to clipboard
Paste from clipboard
Edit Properties
Undo the last deletion
Delete the word to the right
Delete the word to the left
Delete
Negate the character to the left
Find
Replace
Refresh the screen
Selecting
To select
The following screen
The previous screen
The word to the right of the insertion
point
The word to the left of the insertion point
The object or symbol to the left of the
insertion point
The object or symbol to the right of the
insertion point
Everything in the document
Everything between the insertion point
and the start of the line
Everything between the insertion point
and the end of the line
Everything between the insertion point
and the start of the document
Everything between the insertion point
and the end of the document
To choose a command

Press
CTRL + C
CTRL + X
CTRL + V
CTRL +F5
CTRL + Z
CTRL + DELETE
CTRL + BACKSPACE
DELETE
CTRL + N
CTRL + Q
CTRL + W
ESC

or SHIFT + ESC

Press
SHIFT + PAGE DOWN
SHIFT + PAGE UP
CTRL + SHIFT + RIGHT ARROW
CTRL + SHIFT + LEFT ARROW
SHIFT + LEFT ARROW
SHIFT + RIGHT ARROW
CTRL + A
SHIFT + HOME
SHIFT + END
CTRL + SHIFT + HOME
CTRL + SHIFT + END
ALT +the Accelerator keys (the underlined letters for the menu and
command)

Entering Mathematics and Text
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Entering Mathematics and Text
Toggling Between Mathematics and Text
To

Press*

Toggle math/text

CTRL + M

or CTRL + T or INSERT

* Assumes default user settings

Entering Mathematical Objects and Punctuation
To enter

Press

Fraction
Radical
Superscript
Subscript
Summation
Integral
Parentheses

CTRL + F

Square brackets
Angle brackets
Braces

CTRL +[

Display
Absolute value
Norm
Required space
Nonbreaking space
Thin space
Thick space
“ (double open quote)
” (double close quote)
- (intraword dash or hyphen)
– (en dash)
— (em dash)
- (Discretionary hyphen)
¿ (inverted question mark)
¡ (inverted exclamation point)

CTRL + R
CTRL + H
CTRL + L

or CTRL +/
or CTRL +2
or CTRL +3
or CTRL +4

or CTRL +1
or CTRL + UP ARROW
or CTRL + DOWN ARROW

CTRL +7
CTRL + I
CTRL +9

or CTRL +8
or CTRL +0
or CTRL +)
or CTRL +]

or CTRL +6

or CTRL +}

or CTRL +5

or CTRL +(

CTRL +<
CTRL +{
CTRL + D
CTRL +n
CTRL +j ( CTRL + SHIFT +n)
SHIFT + SPACEBAR
CTRL + SPACEBAR
CTRL +,
CTRL + SHIFT + SPACEBAR

Single open quote (`) twice
Single close quote (') twice
Hyphen (-)
Hyphen (-) twice
Hyphen (-) three times
CTRL +– ( CTRL + hyphen twice)*
? followed by `
! followed by `

* Visible only when Invisibles are displayed
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Appendix B Keyboard Shortcuts
Entering Symbols and Characters
To enter

Press CTRL + S
then press

!
"

1
2
3
4
5
6
7
8

#
\
[

6=
2
N
R

;
Q
\
P
@

9 or 0 or ( or )
=
w
e
r or R
t or T
i
o
p
[ or ]
a
s
d
f or F

To enter

_
r
+
)
*
(
=
@
2
=
1
}

8
L

^
:

h or H
l or L
x
Last matrix
created

m

Press CTRL + S
then press
c
v
b
n
$
!
@
#
%
_
+
W
E
I
P
{ or }
A
S
D
X
C
V
N
<

9

>
z
M

Entering Mathematics and Text
Entering Mathematical Accents
To enter accents
â
ã
á
à
a
ä
ā
~a

Press
CTRL +^( CTRL + SHIFT +6)
CTRL +~( CTRL + SHIFT +`)
CTRL +'
CTRL +`
CTRL +.
CTRL +” ( CTRL + SHIFT +')
CTRL +_ ( CTRL + SHIFT +-)
CTRL +-

Entering Greek Characters
To enter

Press CTRL + G
then press

alpha
beta
gamma
delta
epsilon

"

zeta
eta
theta
#
iota
kappa
{
lambda
mu
nu
xi

a
b
g
G
d
D
e
E
z
h
y
Z
Y
i
k
K
l
L
m
n
x
X

To enter

Press CTRL + G
then press

pi
$
rho
%
sigma
&
tau
upsilon
phi
'
chi
psi
omega

!

digamma

z

p
P
v
r
R
s
S
T
t
u
U
f
F
j
q
c
C
w
W
I

81

82

Appendix B Keyboard Shortcuts
Entering ANSI Characters
The ANSI codes depend on the Windows code page in use. The sequences in the table
below are for U.S. Windows systems.
I To enter an ANSI character
Hold down the ALT key and on the numeric keypad, type 0 and the number for the
ANSI character you want, then release the ALT key.
To
enter
space

Type
0+
160

To
enter
¸

Type
0+
184

To
enter
Ð

Type
0+
208

To
enter
è

Type
0+
232

¡

161

1

185

Ñ

209

é

233

c/

162

o

186

Ò

210

ê

234

£

163

»

187

Ó

211

ë

235

164

188

Ô

212

ì

236

U

165

189

Õ

213

í

237

j

166

190

Ö

214

î

238

§

167

¿

191

215

ï

239

¨

168

À

192

Ø

216

ð

240

c

169

Á

193

Ù

217

ñ

241

a

170

Â

194

Ú

218

ò

242

«

171

Ã

195

Û

219

ó

243

:

172

Ä

196

Ü

220

ô

244

173

Å

197

Ý

221

õ

245

174
175

Æ
Ç

198
199

Þ
ß

222
223

ö

246
247

176

È

200

à

224

ø

248

–

R

¯

177

É

201

á

225

ù

249

2

178

Ê

202

â

226

ú

250

3

179

Ë

203

ã

227

û

251

´

180

Ì

204

ä

228

ü

252

181

Í

205

å

229

ý

253

182

Î

206

æ

230

þ

254

183

Ï

207

ç

231

ÿ

255

{

Index
accents, 81
adding tags, 24
additional information
documentation, 69
technical support, 71
typesetting, 68
appearance of documents
about, 4
modifying the style, 22
on screen, 20, 62
style, 20
text format, 21
typesetting speci cations,
64
with typesetting, 20, 62, 64
without typesetting, 20
bibliographies, 67
BIBTEX, 67
body math, 20
body tags, 21
body text, 22
bold, 22
browsing the Internet, 11, 29
buttons, toolbar, 73
centering, 21
characters and symbols
accents, 81
ANSI characters, 82
entering, 15
Greek characters, 81
mathematics, 80
properties, 16
symbol panels, 15, 35
checking equalities, 46
citations, 67
class options, 64
cloning tags, 24
closing documents, 11
combining terms, 43
compiling documents, 64
computations
checking equalities, 46
combining terms, 43
computing in place, 55

computing statistics, 58
computing with units of
measure, 59
evaluating, 40
evaluating numerically, 40
expanding expressions, 44
factoring expressions, 42
introduction, 9
matrix operations, 56
plotting, 51
simplifying expressions, 45
solving differential equations, 57
solving expressions, 47
stopping, 39
working with polynomials,
49
Compute menu commands
Check Equality, 46
Combine, 43
Evaluate, 40
Evaluate Numerically, 40
Expand, 44
Factor, 42
Matrix, 56
Plot 2D, 51
Plot 3D, 53
Polynomials, 49
Simplify, 45
Solve Exact, 47
Solve Numeric, 47
Solve ODE, 57
Statistics, 58
Compute toolbar, 39, 73
computing in place, 55
conversion with units, 59
copy, 16
course materials, creating, 60
cross-references
creating, 66
in PDF les, 65
.cst le, 20
cursor, 13
customer support, 71
customizing the program, 33
cut, 16

default settings
function keys, 36
program defaults, 37
device independent (DVI)
les, 62
differential equations, 57
displayed mathematics, 19
displaying toolbars, 14
docking toolbars, 33
document appearance
about, 4
modifying the style, 22
on screen, 20, 62
style, 20
text format, 21
typesetting speci cations,
64
with typesetting, 20, 62, 64
without typesetting, 20
Document Manager, 31
document windows, 35
documentation
for LATEX, 68
online Help, 70
program, 68, 69
documents
closing, 11
compiling, 64
document elements, 65
exporting, 28, 30
formatting, 20
new, 14
on the Web, 29
opening, 14
previewing and printing,
28, 63
saving, 27
shells, 14, 64
style, 20, 22
typesetting, 61
view, 35
window, 33
drag and drop, 16
DVI les
compiling, 62
previewing and printing, 63
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Index
editing
mathematics, 20
shortcuts, 78
text, 16
Editing toolbar, 73
emphasizing text, 22
entering mathematics, 16
entering text, 15
evaluating expressions, 39
Exam Builder, 60
Exam toolbar, 73
exercises
checking equalities, 46
combining terms, 43
computing in place, 55
computing statistics, 58
computing with units of
measure, 59
creating exams, 60
evaluating, 40
evaluating numerically, 40
expanding expressions, 44
factoring, 42
matrix operations, 56
plotting, 51
simplifying expressions, 45
solving differential equations, 57
solving expressions, 47
working with polynomials,
49
expanding expressions, 44
exporting a document
HTML les, 30
portable LATEX les, 27
RTF les, 28
factoring expressions, 42
Field toolbar, 65, 73
elds, 65
le formats
DVI les, 63
PDF les, 64
RTF les, 28
.tex les, 27
les
DVI les, 63
exporting, 28, 30
formatting, 20
HTML les, 30
opening, 14

PDF les, 29, 63
portable LATEX les, 27
previewing and printing, 28
RTF les, 28
saving, 27
typesetting, 61
lters
HTML lter, 30
portable LATEX lter, 27
oating a toolbar, 33
fonts
properties, 24
text tags, 22
footnotes, 67
foreign characters, 15
formatting
about, 4
modifying the style, 23
on screen, 20
style, 20
text format, 21
typesetting speci cations,
20, 64
with typesetting, 20, 62, 64
without typesetting, 20
fractions, 17
fragments, 19
Fragments toolbar, 19, 74
function key assignments, 21,
36
Greek characters, 81
hardware requirements, 5
headings, 21
help, 70
Help menu commands, 70
History toolbar, 74
HTML les, 30
hyperref package, 65
hypertext links
creating, 25
from cross-references, 65
hyperref package, 65
in PDF les, 29
jumping with, 26
in-line mathematics, 19
inherited tag properties, 23
insertion point, 13
installing the program

installation requirements, 5
on personal computers, 5
program license, 5
Internet, 11, 29
italics, 22
item tags, 22
jumping with hypertext, 26
keyboard shortcuts, 77
keys, creating, 26, 66
LATEX
class options, 64
compiling, 64
described, 62
document appearance, 64
DVI les, 62
packages, 64
PDF les, 62
portable LATEX les, 27
resources, 68
lead-in object, 24
learning the program, 72
leaving the program, 11
licensing the program, 5
limits, 19
Link toolbar, 74
links
creating, 25
from cross-references, 65
hyperref package, 65
in PDF les, 29
jumping with, 26
to the Internet, 31
lists
creating, 22
lead-in object, 24
logical design, 3
MacKichan, contacting, 71
magni cation, 36
margin notes, 67
margins, 25
markers, creating, 26, 66
Math toolbars, 17, 74
Math/Text toggle, 8, 15, 16
mathematical characters and
symbols
accents, 81
ANSI characters, 82

Index
entering, 15
Greek characters, 81
mathematics, 80
properties, 16
symbol panels, 15, 35
mathematical objects
entering, 17, 39, 79
templates, 17
mathematical operators, 18
mathematics
body math paragraphs, 20
computations, 39
computing in place, 55
different from text, 16
displayed, 19
editing, 20
entering, 16, 39
in-line, 19
Math/Text toggle, 16
screen appearance, 16
shortcuts, 79
stopping computations, 39
matrix
computations, 56
entering, 18
Microsoft Windows, 5
modifying page setup, 25
modifying the style, 23
Navigate toolbar, 74
new document, 7
non-English characters, 15
notes, 67
online documentation, 69, 70
online documents, 29
online Help, 70
Open Location, 11, 31
opening documents, 14
opening the program, 5
opening websites, 11, 29
operators, mathematical, 18
packages, 64
page format
headers and footers, 25
margins, 25
modifying the style, 23
typesetting speci cations,
22, 62
page numbering, 25

paragraphs
format, 24
text and mathematics in, 15
parentheses, 18
paste, 16
PDF les
creating, 29
previewing and printing, 63
typesetting, 62
PDF LATEX, 62
PDF TEX, 62
personal computer installations, 5
physical units, 59
plotting
mathematics, 10, 39, 51
plot captions, 24
polynomials, 49
popup lists, 21
Portable Document Format
(PDF), 62
portable LATEX les, 27
previewing documents
with typesetting, 63
without typesetting, 28
print style
document appearance, 20
modifying, 22
printing documents
from preview screen, 29
previewing before, 63
with typesetting, 63
without typesetting, 10, 29
product features, 1, 2
program
leaving, 11
opening, 7
program defaults, 37
program installation
obtaining a license, 5
personal computer, 5
requirements, 5
program resources
online Help, 70
technical support, 71
website, 71
program window, 7, 13
properties
Context menu, 16
editing, 16, 20
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tags, 21, 23
radicals, 40
registering the program, 5
Remove Item Tag button, 22
Rich Text Format (RTF) les,
28
saving documents, 11, 27
screen appearance, 9, 20, 21,
36
scrolling, 77
section headings, 21
section tags, 21
selecting mathematics and
text, 78
settings
function keys, 36
program defaults, 37
shell documents, 14, 64
shortcuts, 77
simplifying expressions, 45
software requirements, 5
solving expressions, 47
speci cations, typesetting, 20,
64
spell checks, 16
Standard toolbar, 13, 75
starting mathematics, 16
starting the program, 5
statistics, 58
Stop toolbar, 39, 75
stopping a computation, 39
style
document appearance, 20
modifying, 23
subscripts and superscripts, 18
Symbol Cache toolbar, 17, 35,
75
symbol panels
customizing, 34
entering symbols from, 15
Symbol Panels toolbar, 15, 75
symbols and characters
accents, 81
ANSI characters, 82
entering, 15
Greek characters, 81
mathematics, 80
properties, 16
symbol panels, 15, 35
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Index
tables, 15
tag properties, 4, 23
Tag toolbar, 21, 75
tagged text, 21
tags
adding, 24
formatting with, 21
function key assignments,
36
properties, 4
technical support, 71
templates, 17
TEX
entering mathematics, 17
elds, 65
LATEX, 62
PDF LATEX, 62
pdfTEX, 62
resources, 68
TrueTEX, 62
typesetting, 61, 64
.tex les
on the web, 31
saving, 27
text
different from mathematics,
16
editing, 16
entering, 15
formatting, 21
screen appearance, 9, 21
text tags, 22
toll-free number, 71
toolbars
buttons, 73

Compute toolbar, 39, 73
customizing, 33
displaying, 8, 14
docking, 33
Editing toolbar, 73
Exam toolbar, 73
Field toolbar, 65, 73
oating, 33
Fragments toolbar, 19, 74
History toolbar, 74
illustrated, 73–75
Link toolbar, 74
Math toolbars, 17, 74
Navigate toolbar, 74
Standard toolbar, 13, 61, 75
Stop toolbar, 39, 75
Symbol Cache toolbar, 17,
35, 75
Symbol Panels toolbar, 15,
75
Tag toolbar, 21, 75
Typeset Object toolbar, 65,
76
Typeset toolbar, 61, 76
viewing, 8, 14
tooltips, 13
troubleshooting, 71
TrueTEX, 62
tutorial exercises, 72
Typeset Object toolbar, 65, 76
Typeset toolbar, 29, 61, 76
typesetting
about, 61
appearance, 65
bibliographies, 67

citations, 68
class options, 64
cross-references, 66
DVI les, 62
footnotes, 67
LATEX packages, 64
PDF les, 29
previewing and printing, 63
process, 62
resources, 68
speci cations, 20, 64
undo, 16
Uniform Resource Locator
(URL), 71
unit names, 59
units of measure, 59
unwrapping les, 33
URL, 71
View menu commands, 36
viewing toolbars, 14
visual design, 3
website for MacKichan, 71
windows
customizing, 35
document window, 33
program window, 7, 13
Windows, Microsoft, 5
World Wide Web, 11, 29
wrapping les, 32
zoom factor, 36

