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CompassAA™v3.50 Quick Start Guide – AA Multiple Image Data
Demo 

Purpose of this Document 
This document is meant to introduce the new or beginning user to CompassAA™v3.50.  Its intent is that

it be used as a guide to quickly open and use a set of known data to check the functionality of the newly 

installed CompassAA™v3.50 tool.  It can also give the user a snapshot of the process and features of

the tool. 

How Does CompassAA™v3.50 Benefit You?

 CompassAA™v3.50 is a streamlined, fast, and complete solution to verify the accuracy and quality

of orthophotos.

 Consistently produces documentation using standard statistical methodologies (e.g. NSSDA, CE90, 
and CE95) for quality assurance of geo-referenced imagery data.

 This easily mastered tool eliminates over 90% of the time and cost of lengthy, expensive, 
inconsistent, and outdated manual accuracy verification.

 Standardizes your data and product accuracy by guiding users through consistent data check process 
for the producer, customer, and end user of orthophotos.

Conventional Steps to Use CompassAA™v3.50

A more detailed step by step process will be presented in the next section of this document. 

1. Open new or existing project.

2. Setup metadata by using Project Information/Add Project Information.

3. Select Project Information/Add Images.  Imagery and collected ground control points need to

match using a projected coordinate system.

 NEW for CompassAA™v3.50 – There is now the ability to create a tiled index shape-file internal

to CompassAA™v3.50.  The input files used needs to be .TIF file imagery and to have the correct

projected coordinates.
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4. Add the checkpoint .CSV file by selecting Project Information/Add Surveyed Locations.

5. Use Photo Book and Select Point to visually select photo identifiable Ground Control Points (GCP) to

compare to the geo-referenced imagery

6. Explore differences by comparing surveyed locations with orthorectified imagery data.  Use the

CompassAA Calculate function to view error statistics for a variety of scenarios.

7. Generate Report(s).

Note: The image data and checkpoint data must all 

be in the same map projection with common datum 

and spheroid.  CompassAA does not support 

automatic projection transformation. 
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First Steps 

Open the CompassAA™v3.50 application by clicking on the desktop icon.

Use the provided demo data (C:\CDIData\CompassAA_Demos\AA_Multiple Image Data Demo) that has been 

placed in the C:\CDIdata folder - by you, the user) 

***Optional ***  To view the completed CompassAA QuickStart project, open CompassAA™v 3.50, click on the

menu command, File -> Open -> Project.  Navigate to C:\\CDIData\CompassAA_Demos\AA_Multiple Image 

Data Demo\05_Reports, and select the Multiple Image Demo.AAP file.  This .AAP (Accuracy Analyst Project) 

file contains the saved project data, created from the CompassAA QuickStart instructions below. 

The folder structure in the demo data sets is the structure we use and recommend in our production.  However, 

CompassAA is a flexible tool and can be adapted to your own project data directory structure. 

Using CompassAA for the first time 

1. Select File-> New-> Multiple Image Project

2. Select Project Information-> Add Project Information

Fill in the data as suggested in the graphic below.  This becomes the metadata for the report.  CompassAA will 

not allow the user to move forward without all the fields being completed. 

NOTE 

If at any given time you get an error window 

like below, please click on Continue and 

proceed with the operation of the tool. 

As a normal practice, it is always a good habit 

to save your work. 

mailto:accuracytools@compassdatainc.com


CompassAA™v3.50 Quick Start Guide – Multiple Image

Page 4 of 14 Released September 25, 2018 

CompassData, Inc. |7074 S. Revere Parkway, Centennial, CO  80112 | 303-627-4058 | accuracytools@compassdatainc.com 

3. Select Project Information -> Add Index and Images.  A window should appear to let you browse to the

project folders containing the project associated images and data.  The window below should appear.  We will

now add the minimum data required (shown by the * next to the fields).

3a. Select the Index File Name button and browse to the location below.  This is the location of the shapefile 

(.shp) that has the multiple image index previously created.  Select Index_Shape_File.shp and Open this file.  

Another method might be used instead of browsing to the shapefile.  You can also cut and paste from the 

Windows Explorer address bar to the Index File Name field or any of the other Folder Path fields. 

If you would like to create a new tiled index shapefile use a new feature found in CompassAA v3.50 and use the

GDal TIndex menu command.  On the application main menu, click on Tools -> Gdal Tindex and follow the 

steps. 

3b. After selecting the Index_Shape_File.shp file, click on the Select Field Name pull down menu.  Choose (in 

this instance) LOCATION.  This selection tells the program which attribute table column in the Index Shape File 

contains the names of the images to be used. 
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3c. Returning to the Add Tile Index and Images window select the Image Folder Path 1 button and browse to the 

01_Imagery folder that contains the images used for this demo.  Click OK. 

3d. As a last step in selecting what images you use, click on the Image Type pull down menu.  For this demo data 

set we are using SID format image files.  Click OK to close the window. 
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3e. Click OK in the Add Tile Index and Images window.  The window will close and you will see the application 

window view below. 

4. To make sure that everything is working correctly, do the following:  Select Browse Image in the main menu

area and then left click anywhere inside one of the index shapes.  By left clicking inside the upper left index

shape you should see the single image appear.  You can open multiple images by selecting Drag Load Images.

Move pointer to any displayed index shape after selecting Drag Load Images and press the left button down and

then drag the pointer diagonally to another shape (creating a selection fence).  Multiple images will be

displayed.

Experiment with zooming, panning and viewing images using the interactive menu tools highlighted above.  

These tools are useful to explore the images.  Try using more typical Windows adjustments using the mouse click 

and drag manipulations.  Move mouse over the perimeter boundary of the application window.  The mouse 

pointer will change to a respective resizing pointer that will allow you to stretch or shrink the application 

window.  Similar features for modifying the view ports inside the application window are adjustable too.  Grab 

the boundary edge between the Map Image area and the Coordinates and Offsets data display.  With the left 

mouse button held down, you can make the map area bigger or smaller by dragging and releasing.  Always 

select the Full Extent graphic icon (magnifying glass) in the main menu banner to refresh the entire image area 

after resizing the map area. 
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When you are ready to go to the next step, click on the Zoom to Full Extent tool (to the far right of the group) to 

reset the image view. 

5. Save your project file to an .AAP (Accuracy Analyst Project) file for future use.  Select File -> Save As and then

browse to the 05_Reports folder location below and Save the .AAP to a file named Multiple Image Demo

User1.AAP.  You will be prompted that the file does not exist, and asked if you want to create the file.  Select

Yes.

Input of Ground Control Data 

6. The next step is to add the surveyed ground control .csv file that also contains file names for ground control

photos and site sketches.  Select Project Information -> Add Surveyed Locations -> Load CSV / Checkpoint File.

Browse to the 02_Check Points folder location below and select the KAPA_Control_For_AA.csv file.
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The .csv file is a critical element of CompassAA and a successful user needs to understand it.  Take time to look 

how this demo .csv file is set up and use it as an example for your own future projects.  The .csv lists records that 

correspond to file names found in the demo data sets 03_Survey_Pics and 04_Station_Diagrams folders.  Your 

file names don’t need to use the same CompassData naming convention as shown, but a unique, identifying 

name must be 

used for photos 

and site sketches. 

After selecting the .csv file the window above should appear. 

6a. Select the applicable fields to match the proper columns.  Remember, Northing is always the Y axis and 

Easting is always the X axis.  Switching these is a common error.  Make sure to select the Ignore First Row radio 

button if there is header information in the .csv file.  In your future project data, the .csv file can be edited or 

created in any order that fits your project or your data requirements. 
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6b. For the Photo and Site Sketch Columns navigate to the 03_Survey_Pics folder or the 04_Station_Diagrams 

folder.  To access multiple photo folders, click on the + button and browse to the proper folder location.  For 

multiple images, all the site photos can be in the same folder but the names need to be similar to the naming 

convention in the demo.  The files must be in .jpg format. 
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6c. After confirming that the columns of data are selected correctly as in the 6a graphic above, click the Column 

Identifier Form window OK button.   

The application window should appear as below. 

Visual verification using Photo Book 

7. Now, we will photo identify a point and use the provided tools to create a report.

If you have saved your work before, then do so again by clicking File -> Save. 

Use the Zoom Factor (ZF) slide bar to adjust the zoom.  You can also type in the Current Scale by clicking on the 

value and entering 150.  (For this demo data satellite imagery 1:150 is a good scale for reviewing and selecting 

points.)  Now left click on the Save Context Extent button on the right to stay at the same scale while going from 

point to point. 

Select Photo Book from the application command menu.  As you click through the different ground control 

points in the Coordinates and Offset table photos in the Photo Book will update itself to match the selected 

point.  The main screen image will also swap out to match the ground control point selected.  Also notice that in 

the Error Plots and the Vector Offset Plot the current point being edited is identified by displaying a red circle 

around the point. 

7a. Click on Select Point from the application window menu.  When a pointer arrow changes to a crosshair you 

are ready to choose your first ground control point location.  The Green Dot represents the “True Location” of 

the point as derived from the ground control.  Using the Images and Site Sketches in the Photo Book, select the 
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image derived location of the point.  If you select a point and then wish to adjust it, just click on the new location 

and the point will move.  You can also zoom in, zoom out and pan using the interactive menu tools. 

Notice the automatic calculation of the delta X and delta Y values.  These are the values that will be used in our 

final report. 

7b. Select the remaining ground control points using the viewing and selection tools. 

Point 3 (ID column) is an example of a point that is unusable, in this instance because the feature is out of 

bounds (OB).  By clicking on the check mark, the point is unselected and a variety of options of why point is 

unusable are given. Unused points and the reason selected are displayed in the CompassAA produced report.  

The list of reasons can be customized by the user in the Tools ->Options menu. 

The Photo Book is important in selecting which images will appear in the report as well.  As of v3.3, you can now 

select up to two photos for each ground control point.  These will be placed in the report in the lower left and 

lower right of the detail page.  The bottom-left is the default image.  You can select one other image to be 

placed in the bottom-right.  This is done by clicking on the additional image that you would like to appear in the 

bottom-right corner of the report page. 

All images need to be in a .jpg format.  Any image could be used if it is in a jpg file format and fits the 

proportions of a standard sized photo. 
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When Select Point process is complete and each viable Ground control point has been reviewed, left click on the 

Calculate button located on the right side of the application window.  The error statistics are calculated and 

graphically displayed in the lower left of the application window. 

A useful tool is to adjust the scale of the Vector Offset Plot (labeled as Scale to the left of the Vector Offset Plot 

area).  Adjusting the scale to 400 makes it easier to identify shifts in the imagery, to see which areas of the 

image has more/less error, to see any Systematic Errors or Outlier Points.  As different points are selected in the 

Coordinates and Offset table, they are highlighted in the Vector Offset Plot. 

7c. Left click on the Close button in the Photo Book window to close it.  Select File -> Save to save the current 

project. 
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Creating a CompassAA Data Verification and Validation Report 

The next step is to create the report.  Before creating our first report, review the scale currently in the Save 

context extent.  This determines the image size and level of detail of the individual ground control points 

displayed in the final report. 

8. To create a report, select Tools -> Report from the application menu.

Choose the Select Statistics View button in the Report Customization window to customize the reported 

statistics. 

A company logo can also be easily added to the report by referencing a .jpg saved image of the graphic. 

mailto:accuracytools@compassdatainc.com


CompassAA™v3.50 Quick Start Guide – Multiple Image

Page 14 of 14 Released September 25, 2018 

CompassData, Inc. |7074 S. Revere Parkway, Centennial, CO  80112 | 303-627-4058 | accuracytools@compassdatainc.com 

8a.  When finished left click on the Save button.  Browse to the 05_Reports folder location shown below and 

Save the .pdf report to Final Report User1.pdf. 

The .pdf file will either open automatically or you will need to browse to its saved location and double click on 
it. 

If you wish to save your just processed CompassAA project data, click on File  Save As menu commands and 

name your project file as needed.  Otherwise click on Close or Exit to end your first CompassAA 3.50 session.

Congratulations! 

You have now successfully used CompassAA 3.50 to verify the accuracy and quality of georeferenced image
data in a consistent, standardized, easily mastered, and fast process.  You verified data accuracy, controlled 
quality, and created a customized professional, meaningful report. 
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