
Virtual Cell Version 4.0 Membrane Potential 

Creating the BioModel

Creating the Application

• Application I -Studying voltage changes in a compartmental model  
• Application II - Studying voltage, sodium, and potassium changes in a compartmental model  
• Application lll - Studying voltage, sodium and potassium changes in a spatial model  
• Application IV - Voltage Clamp  

Running the Simulation 

Introduction 

The following description details the implementation of the Hodgkin-Huxley model into the Virtual Cell Modeling and Simulation 
Framework.  The Hodgkin-Huxley model is the great basis for understanding membrane electrophysiology and is a suitable model 
for demonstrating the powerful functionality of the Electrical Mapping option. The model includes the sodium and potassium 
channels and their gating processes; m and h for activation and inactivation of the sodium gate and n for activation of the 
potassium gate. These processes are treated independently of each other however both depend on membrane potential. The 
variables h,m, and n express the time and voltage dependence of the sodium and potassium conductances. The total ionic current 
is described as the sum of the currents for sodium, potassium and a nonspecific ion (leak current). 

Following the Tutorial 

You can create your own BioModel and Application as you read through the tutorial or you may choose to load the public version 
of this model. Go to File>Open>BioModel>Model Neighborhood>tutorial>Hodgkin_Huxley and press the Open button. The 
BioModel has four different Applications associated with it: voltage only, combined_comp, combined spatial, and voltage_clamp. 
Each application has its own simulation results. 

Creating the biological model 

Creating and Defining Compartments 

The biological model is defined as a collection of biochemical reactions acting on a 
set of molecular species localized in specific cellular structures. The cellular 
structures are defined as mutually exclusive compartments within the cells, as well 
as membranes that separate them. The compartments represent three-
dimensional volumetric regions while the membranes represent two-dimensional 
surfaces separating the compartments. All structures can contain molecular 
species and a collection of reactions that describe the biochemical behavior of 
those species within that structure. Keep in mind when developing your model that 
it must be mapped to a specific cellular geometry before any quantitative 
simulation or analysis can be performed. 

When the software initiates, you are presented with a new model containing a 
single compartment. Select the compartment once with the left mouse button, the 
region will turn red, use the right mouse button to access the Properties menu. 
Enter the name "extracellular" in the Feature Name text field and press OK. 

Select the feature tool  once and click in the extracellular compartment, alternatively you may use the right mouse button to 
access the Add Feature menu option. A New Feature dialog will open. Enter "intracellular in the Feature Name text field and enter 
"membrane" in the Membrane Name text field; press Add Feature. 
 
 
 
 
 
 
 
 
 



Creating Species 

Extracellular Species 

Select the species tool  and click in the extracellular compartment.  The Add New Species 
dialog will appear. Enter "K", for potassium, in the Name text field; press Add. Follow the same 
procedure for adding sodium, Na, and a nonspecific ion, ion. This nonspecific ion is the 
unknown ion active in the leak current; a small voltage-independent conductance. 

 
Membrane Species  

Use the species tool as you did for creating the extracellular species. This time you will place the species, which will represent the 
activation and inactivation gates in open and closed states, on the membrane. Sodium channels have two gates: one for 
activation, m, and one for inactivation, h.The sodium activation gate is closed at rest; depolarization causes it to open rapidly. The 
sodium inactivation gate is open at rest; depolarization causes it to close slowly. After depolarization, m recovers rapidly and h 
slowly. Potassium channels are hypothesized to have only one gate, n. This gate is closed at rest; depolarization causes it to open 
slowly. Create the following membrane Species: 

• Potassium Channel Inactivation Gate-closed "n_c"  
• Potassium Channel Inactivation Gate-open "n_o"  
• Sodium Channel Inactivation Gate-closed "h_c"  
• Sodium Channel Inactivation Gate-open "h_o"  
• Sodium Channel Activation Gate-open "m_o"  
• Sodium Channel Activation Gate-closed "m_c"  

Intracellular Species 

Use the species tool for creating the intracellular species Potassium, Sodium, and a nonspecific ion. Since these species were 
already created in the extracellular compartment, you can select them and use the right mouse button to access the Edit>Copy 
command. Click in the intracellular compartment and use the Edit>Paste command, via the right mouse button, to add the newly 
created Species. 

 
Adding Reactions  

Membrane Reactions 

Once you have added all the species in your model you can create your 
reactions. Select the membrane with your left mouse button and then use 
the right mouse button and select Reactions.  

In the Reactions dialog you will set up a total of six reactions; three will be 
the fluxes across the membrane for the three species defined in the 
extracellular and intracellular compartments and three will be for defining 
the sodium and potassium gates. Organize the species according to the 
image. 

Click on the Reaction tool  and click again in the membrane compartment.  

Create the potassium gate first. Use the line tool  to connect n_c and n_o to the 
reaction icon. You always connect from the species to the reaction icon. 
 
Once you have made the connections, select the reaction icon and use the right 
mouse button to access the Properties menu that will open the Reaction Kinetics 
dialog for those species. 

 
Click the Rename button and enter KGate, Potassium Gate, for this reaction. Do not 
include the electric current and select General for the kinetic type. 
Prior to entering your rate equations, please note the units are molecules/(sec-µm2) 
and the inward current is pA/µm2. Please also note the numerical signs. In the Virtual 
Cell, the software is designed such that the voltage is measured from the outside of 
the cell going into the cell. Often such measurements are made in the reverse manner. 



Double click the Expression text field for the reaction rate J and enter the formula that defines the workings of the gate activation 
(n): (1000.0 * ((alpha_n * n_c) - (beta_n * n_o))). You now have to define alpha_n and beta_n, the voltage dependent rate 
constants, and any additional parameters introduced within those expressions.  The software will automatically recognize these 
parameters and appear as User Defined.  
 
Double click the Expression field and enter the following equation for alpha_n : (0.01 * (10.0 - V_n) / (exp((0.1 * (10.0 - V_n))) - 
1.0)). Once you enter this you will have to define V_n, the total membrane voltage, as (Voltage_membrane - Vrest_n) and then 
define Vrest_n as -62.0. Define beta_n from the initial rate equation as (0.125 * exp((-V_n/80.0))). 
 
Select the Flux tool  and click in the membrane compartment. Use the line tool to 
connect the extracellular and intracellular K to the icon. Remember to click and drag 
from the species to the flux icon. In addition, you will need to connect n_o to the flux 
icon. Make this connection in the center of the icon and not at the end. Note that the 
words "catalyst" will appear when you make this connection properly.  
 
Select the flux icon and use the right mouse button to access the Properties menu to 
open the Reaction Kinetics dialog. Click the Rename button and enter K Flux. 
Choose the flux carrier by pressing Change and then select K from the list in the Flux 
Carrier Species dialog. Press OK to accept your selection and to close the dialog. Be 
sure that “include molecular  flux” is selected. 
 
Select Nernst conductance for the Kinetic Type and once again note the units. The 
Charge Valence will automatically become active with this selection; leave the charge 
at the default of 1. Define the K Flux conductivity, C,  in the Expression text field where 
the total potassium current is proportional to n4: (gK_max * pow(n_o, 4.0)). Enter the 
maximum conductance for Potassium as .36. Note that the equation for inward current and flux is automatically updated based on 
your conductivity equation. Also note the assumed values for R(gas constant) is 8314.0, T(absolute temperature) is 300, and 
F(Farady's constant) is 96480. 

 
Select the Reaction tool and place it between m_c and m_o. Once again use the line tool 
to connect the species to the icon to create the activation sodium gate. 
 
Rename the reaction as NaGateAct and select the kinetic type to be General. Double 
click the following Expression text fields and enter the following information: 
Reaction Rate, J, : 1000.0 * (alpha_m * m_c - beta_m * m_o) 
Alpha_m, the rate constant for a particle not activating a gate: (0.1 * (25.0 - V_m) / 
(exp((0.1 * (25.0 - V_m))) - 1.0)) 
Beta_m, the rate constant for a particle activating a gate: (4.0 * exp(( - V_m / 18.0))) 
V_m, the total membrane voltage: (Voltage_membrane - Vrest_m), and Vrest_m as - 62.0 
  
 
 
 
 
 

Create the inactive gate by placing another Reaction icon between h_c and h_o, where h is 
the probability that a Na channel is not activated. Open the Reaction Kinetics Editor and 
enter the following information: 
Reaction Name: NaGateInact 
Kinetic type: General 
Reaction Rate: (1000.0 * ((alpha_h * h_c) - (beta_h * h_o))) 
alpha_h: (0.07 * exp(-(0.05 * V_h ))) 
V_h: (Voltage_membrane - Vrest_h) 
beta_h: (1.0 / (exp((0.1 * (30.0 - V_h))) + 1.0)) 
Vrest_h: - 62.0 
The inward current density, I, is predefined and cannot be edited. 
 
Select the Flux tool and click in the membrane compartment. Use the line tool to 
connect the extracellular and intracellular Na to the icon. Remember to click and drag 
from the species to the flux icon. In addition, you will need to connect m_o and h_o to 
the flux icon. Make these connections in the center of the icon and not at the end. 
Note that the words "catalyst" will appear as you make the connections. Select the 
icon and open the flux reaction editor. 
 
Name the reaction Na Flux and change the flux carrier to Na. Select include molecular 
flux, choose Nernst conductance for the kinetic type and leave the charge valence at 
the default 1.  
Maximum sodium conductivity, C: (gNa_max * pow(m_o, 3.0) * h_o)  
gNa_max: 1.2.   
gNa_max assumes the probability that all 3 activation particles (m-activation 
coefficient) have produced an open channel. H represents the inactivation coefficient. 
Once again note the units used in this equation. 
The inward current density, I, and the reaction rate, J, are predefined and cannot be 
edited. 



 
 

Select the flux tool for the last time and place it in the membrane to create the leak flux 
between the intracellular and extracellular nonSpecific Ion. This leak is a voltage-
independent conductance from an ion other than sodium and potassium. 
 
Rename the flux as leak flux and select ion for the flux carrier. Select include molecular 
flux, select General Current Density for the kinetic type and leave the charge valence at 
its default of 1. Define the following: 
flux, inward current density, I: (gL * (Voltage_membrane - VL)).  
gL, the maximum possible leakage conductance: - 0.0030  
VL, the leakage membrane potential: - 51.4. 
The reaction rate, J,  is predefined and cannot be edited. 
 
Close the dialog and save your model before proceeding further. Go to File>Save and 
enter a model name. Next you will create the Applications that implement different 
experimental conditions. You will be using both compartmental and spatial models to 

look at voltage, current and ionic conditions. 
 
 
Creating the Application  

Application l Voltage Only 

You may choose to load the Applications already created or create them yourself. In the Application panel of the Model document, 
go to Application >New and enter voltage_only or if you choose to load the created Application, double click on voltage_only. 

 Structure Mapping 

The first application, a compartmental model, looks only at voltage changes; 
sodium and potassium are fixed concentrations. A compartmental model loads by 
default, so you do not have to do anything in the Structure Mapping panel. Change 
Surf/Vol to 0.1 and leave the VolFract at 0.2. 

Reaction Mapping 

Select the Reaction Mapping tab, make sure all the reactions are enabled. You do 
not have to select Fast reactions for this Application. 

 
Initial Conditions  
Select the Initial Conditions tab and enter the initial values for the species. Be sure 
to set the concentrations for potassium, sodium and the nonSpecific ion to Fixed. 
The values were obtained from steady state values. 
 
Potassium Fixed 397000.0 
non Specific Ion Fixed 100.0 
Sodium - intracellular Fixed 50000.0 
Potassium Channel Inaction Gate - open  0.304015731

Sodium Channel Activation Gate - closed  0.95240929 
Sodium Channel Activation Gate - open  0.04759071 
Sodium Channel Inactivation Gate  0.627122591

Sodium Channel Inactivation Gate  0.372877409

Potassium Channel Inactivation Gate  0.695984269

Potassium - extracellular Fixed 20000.0 
Sodium - extracellular Fixed 437000.0 
non Specific Ion - extracellular Fixed 100.0 
 
 
 
 



Electrical Mapping 

Select the Electrical Mapping tab next. Select calculate V, and enter an initial value of 
- 62.897633102. Leave the specific capacitance at 0.01 pF/µm2. Note the units here 
are pF/µm2 not µF/cm2.  Select Current Clamp in the Electrical Stimulus panel. Press 
the Set…. button  and set the patch electrode feature to intracellular. The ground 
electrode should be set to extracellular. Double click the expression text field for the 
Applied Current Density and enter (- 0.1 * (t < 0.0020)). Press Enter to accept the 
value. Note the negative sign accounts for the direction of the current.  

Save the Application if you have created your own, and proceed to the Simulation tab. 
 
 
 
 
 
 

 
Running the Simulation  

 
You may load the simulation results, which have already been generated, by selecting 
the simulation you are interested in and pressing the Results button. Alternatively you 
may create your own simulation. Select New to create a simulation. Double click in 
the name field and enter a new name or keep the default name.  
 
Press the Edit button to access the Parameters, Mesh, Task and Advanced tabs. For 
this particular application you will not change the Parameters or Mesh. The 
Parameters will remain as defined in the Initial Conditions and the Mesh is disabled 
for compartmental models. Select the Task tab and enter the run parameters for the 
simulation. Start Time: 0, Time Step: 0.1, End Time: 0.02 and Keep every time 
sample. 

Select the Advanced tab and choose the Runge-Kutta-Fehlberg solver. Set the 
Starting and Ending Time Bounds to 0.0 and 0.02. Enter 1.0E-8 for the Minimum Time 
Step, 0.1 for the Default and 1.0E-4 for the Maximum Time Step. The Absolute and 

Relative Error Tolerances should both be 1.0E-9.  

Close the Edit dialog and make sure the simulation is selected. Press the Run button to initiate the simulation. Once the simulation 
has generated results, the Results button will become active. You can review them or wait until the simulation has completed; the 
results will be displayed automatically. 
Review Chapter 8 of the User Guide for information on how to review results.  

Application II - Voltage, sodium, and potassium changes 

Structure Mapping 

Once again you can either create your own application based on the following description or you can load in the Application 
"combined_comp". This Application as with the previous one is a compartmental model so you can leave the Structure Mapping in 
the default setting. Set the Surf/Vol ratio to 0.2 and the VolFract to 0.7.  

Reaction Mapping and Initial Conditions 

The Reaction Mapping tab should have all the reactions Enabled. You will be using the same initial condition values as before 
however this time only the non Specific ion concentrations, intracellular and extracellular, are set to fixed. 

Potassium  397000.0 
non Specific Ion Fixed 100.0 
Sodium - intracellular  50000.0 
Potassium Channel Inaction Gate - open  0.304015731

Sodium Channel Activation Gate - closed  0.95240929 
Sodium Channel Activation Gate - open  0.04759071 



Sodium Channel Inactivation Gate  0.627122591

Sodium Channel Inactivation Gate  0.372877409

Potassium Channel Inactivation Gate  0.695984269

Potassium - extracellular  20000.0 
Sodium - extracellular  437000.0 
non Specific Ion - extracellular Fixed 100.0 

Electrical Mapping 

Select the Electrical Mapping tab and select calculate V under the Membrane Potential Options panel.  Enter an initial voltage 
value of - 62.897633102. Leave the specific capacitance at  0.01 pF/mm2. Under Electrical Stimulus, select Current Clamp.  Set 
the patch electrode Feature to intracellular. Enter the Applied Current Density as (- 0.1 * (t < 0.05)); press Enter to accept the 
value. 

Running the Simulation 

Proceed to the Simulation panel and create a new simulation or review the simulation and stored results. If you are creating a new 
simulation, click on the Edit button, select the Task tab and enter the run parameters for the simulation as follows: 

Start Time: 0 
Time Step: 0.1 
End Time: 0.02 
Keep every time sample 

Click the Advanced tab and use the following conditions for the Runge-Kutta-Fehlberg solver:  

Starting Time Bounds 0.0 Maximum Time Step 1.0E-4 
Ending 0.02 Absolute Error Tolerances 1.0E-9 
Minimum Time Step 1.0E-8 Relative Error Tolerances 1.0E-9 
Default Time Step  0.1   

Close the Edit dialog and run the simulation. Once again be sure that the simulation is selected before you press Run. 

Application lll - Voltage, sodium, and potassium changes in a spatial model 

This is a Spatial Application in which you can use the Application and Geometry that are already created or you can create your 
own. If you use the Application that is already created, the Geometry and the Structure mapping will be complete. If you choose to 
create your own Application you can either load the Geometry that was already created or once again, you can create your own. 
To load the Geometry that was already created, open the Application and go to View/Change Geometry>Change Geometry> 
Geometry Neighborhood>tutorial>combined_spatial1. 

 Creating the Geometry 

In the BioModel document go to File>New>Geometry>Analytic>2-D. In the 
Geometry Editor, click Add. Select the second subvolume (represented by the 
brown color), double click in the value text field and enter the following equation: 
((x*x+y*y)<100.0). Press Front to bring that subvolume in front of the other. 
Leave the original subvolume(represented by the red color) as 1.0. 

 
Press Change Domain. Enter 21 for both x and y for the subvolume size, and for 
the Origin enter -10.5 for both x and y. Press OK to close the dialog. Go to 
File>Save As and save the geometry you just created. 
 
 
 
 
 
 
 
 
 



Creating the Application  

Structure Mapping 

Return to the BioModel Workspace and create a new Application as you did for 
the previous examples. In the Application dialog, load the geometry you created. 
Go to View/Change Geometry and navigate to your directory and select your 
Geometry. 
 
Select the line tool and map the compartments; map extracellular to subVolume1 
and intracellular to subVolume0. Select the intracellular structure at the bottom of 
the dialog. Notice the Set Boundary Types becomes active. Press this button 
and set the boundary types to Flux for the X- and Y- coordinates, press OK to 
close the dialog. Select the extracellular structure and click Set Boundary Types. 
Set the boundary conditions to Flux for both the X and Y axes. Press OK to 
accept the changes and to close the dialog. 
 
 
Reaction Mapping  

There is nothing to change on this tab, leave all the reactions Enabled. 

Initial Conditions 

Select the Initial Conditions tab. For each species present, double click on the Initial conditions field and enter the following 
values: 
 

Potassium  397000.0 
non Specific Ion Fixed 0.0 
Sodium - intracellular  50000.0 
Potassium Channel Inaction Gate - open  0.304015731

Sodium Channel Activation Gate - closed  0.95240929

Sodium Channel Activation Gate - open  0.04759071

Sodium Channel Inactivation Gate  0.627122591

Sodium Channel Inactivation Gate  0.372877409

Potassium Channel Inactivation Gate  0.695984269

Potassium - extracellular  20000.0 
Sodium - extracellular  437000.0 
non Specific Ion - extracellular Fixed 0.0 
 
Set the concentrations to Fixed for the intracellular and extracellular non Specific ion. In addition, select intracellular potassium 
and set the diffusion rate constant to 1000000.00. Do the same for extracellular potassium, and extracellular and intracellular 
sodium. 
 
Electrical Mapping  

Select calculate V, and enter an initial value of - 62.897633102. Leave the specific 
capacitance at 0.01 pF/mm2. Select Current Clamp under Electrical Stimulus. Set 
the Feature to the intracellular compartment for the patch electrode and enter the 
Applied Current Density as -( 0.1 * (t < 0.05)). Save the Application if you have 
created your own and proceed to running the simulation. 

Simulation  

Click on the Simulation tab to access the Simulation panel. You can either create 
your own simulation or review 'Simulation 3' and the results. 



If you are creating a new simulation, click on the Edit button and select the Mesh tab. Enter 43 for the X and Y mesh size 
elements. Select the Task tab and enter the run parameters for the simulation.  

Keep the defaults for the Parameters and Advanced tabs. Close the Edit dialog and run 
the simulation. Once again be sure that the simulation is selected before you press Run 
to initiate the simulation. Once the simulation has generated results, the Results button 
will become active, you can review them or wait until the simulation has completed. The 
results will be displayed automatically. Review chapter 9 of the User Guide for information on how to review results. 

Start Time:  0 
Time Step:  1.0E-5 
End Time:  0.05 
Keep every 10th sample.  

Application IV - Voltage Clamp 

Structure Mapping 

This is another Compartmental Application however in this instance you will use a voltage clamp to measure the voltage 
dependence of the activation and inactivation of ion conductances. Once again, you can use the Application that is already 
created, voltage_clamp, or create your own. If you decide to create your own, you will create another Compartmental model in the 
Structure Mapping panel. Select the Intracellular Compartment and change the Surf/Vol to 0.1 and leave the VolFract at 0.2. 

Initial Conditions 

Select the Initial Conditions tab. For each species present, double click on the Initial conditions field and enter the following 
values: 
Potassium Fixed 20000.0 
Sodium - extracellular Fixed 437000.0 
nonSpecific Ion - extracellular Fixed 100.0 
Potassium- intracellular Fixed 397000.0 
nonSpecific Ion - intracellular Fixed 100.0 
Sodium - intracellular Fixed 50000.0 
Potassium Chan Inactivation Gate-O  0.304015 
Sodium Channel Activation Gate-C  0.95240929

Sodium Channel Activation Gate-O  0.04759071 
Sodium Channel Inactivation Gate-O  0.627122159

Sodium Channel Inactivation Gate-C  0.372877409

Potassium Chan Inactivation Gate-C  0.695984269

 
Please note there are 6 species with fixed concentrations. 

Reaction Mapping 

There is nothing to modify on this tab, leave all the reactions Enabled. 
 
 
Electrical Mapping  

Select calculate V, and enter an initial V value of - 62.897633102. Leave the specific capacitance at 0.01 pF/µm2. Select Voltage 
Clamp under Electrical Stimulus and then select the intracellular compartment by pressing the Set... button.  The Tip position is 
not an option since this is a compartmental model. Double click the Applied Voltage text field and enter (-63.0*cos((100.0*t))); 
press Enter to accept the equation.  

Save the Application if you have created your own, and proceed to the Simulation panel. Once again you can either create your 
own simulation or review the stored simulation, 'Simulation 4', and results. 

Simulation 

Click on the Edit button, select the Task tab and enter the run parameters for the simulation.  
Start Time:  0 
Time Step:  0.1 
End Time:  1.0 
Keep every sample. 



 
Keep the defaults for the Parameters tab.  
Select the Advanced tab; choose the Runge-Kutta-Fehlberg solver. 
 
Starting Time Bounds 0.0 
Ending Time Bounds 1.0 
Minimum Time Step 1.0E-8 
Default Time Step 0.1 
Maximum Time Step 1.0 
Absolute Error Tolerances 1.0E-9 
Relative Error Tolerances 1.0E-9 
Keep every sample, and at 
most 1000 samples. 

 

  
 
Close the Edit dialog and run the simulation. Once again be sure that the simulation is selected before you press Run to initiate 
the simulation. Once the simulation has generated results, the Results button will become active. You can review them or wait 
until the simulation has completed; the results will be displayed automatically. Review chapter 9 of the User Guide for information 
on how to review results. 
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